How to keep tools settings

Good evening,

using RawTherapee 5.9 I have collapsed all tool settings to a minimum and would like to keep them that way:


But when I close RT and open it up again, all tools open up again:


How can I change this behaviour?

This happens, although I had chosen to save the tools settings:


Best wishes


Abends, Hermann-Josef!

Strange — it works as intended up here.
I wonder what differs between your version and mine
(Release-5.9, Manjaro Linux)?

Claes in Lund, Schweden

Hi, @Jossie

After collapsing the tools, try the following: disable the “Automatically save tools’ collapsed/expanded state before exiting” option, click “Save tools’ collapsed/expanded state now”, and then click “OK” (to close the Preferences window and commit your changes).

After closing and opening RawTherapee again, you should find that it starts up with all of the tools in their collapsed state.

1 Like

@Claes and @martbetz

Thank you for your replies. Unfortunately the recipe from martbetz does not work. The tools are again expanded once I reopen RT.


Moinchen, Hermann-Josef!

Are you on a Windows machine,
or a McMachine, or…?

Claes in Lund, Schweden

Guten Morgen Claes,

I am on WIndows11.


OK. I believe that I am beginning to understand…
I just tested this on a Win11 partition.
First of all, RT5.9 takes a l-o-n-g time to start on WIn11 :frowning:

Test this:

a) start RT5.9
b) collapse all tools
c) in Preferences, click button “Save tool collapsed/expanded state now”
d) do NOT tick “Save tool collapsed/expanded state of exit”:

e) restart RT5.9


Claes in Lund, Schweden

Addendum: Hmmm again — this is the same as what @martbetz suggested above. Wonder why my Win11 behaves nicely, while Hermann-josef’s does not?

I wonder if the changes aren’t being written to the ‘options’ file for some reason? Or maybe they are being written, but are somehow being ignored? Could be due to the required permission level not being set?

1 Like

Thanks for your suggestions. But whatever I try, even without closing RT but only closing the image opened in the editor, the tools are expanded again if I open a new image in the editor. Very strange.


It has to do with the privileges!

If I run RT as administrator, the tools are all collapsed, although this was my first call to RT5.9 as administrator. So it obviously took the settings I had stored as a standard user without administrative privileges.



Same behaviour here on Debian Sid since I switched from 5.8 to the dev-versions. The above suggested changes as a workaround were written to the options file with no effect.

Greetings from Germany,

Hi, @robles

Have you tried the final release (i.e. the RawTherapee 5.9 AppImage)?

Devs, by their very nature, are a work in progress; as such, they may not be fully functional.

Hi @martbetz,

yes I’ve tried the 5.9 AppImage, same behaviour. I just mentioned the dev-versions, cause I have this behaviour since the first time I have switched from 5.8 to a higher version. 5.9 just arrived in Debian Sid today with the same behaviour.

I found the reason: It happens when the “Multiple Editor Tabs In Own Window Mode” is selected in the preferences settings. When I switch to “Single Editor Tab Mode” it works.

Greetings, Robert

PS: Thanks to all the developers for their work and this fantastic software!


Well spotted, @robles! I wouldn’t have thought of that. :thinking:

Thanks for sharing the info; posting it here will certainly help others who may encounter a similar issue. :+1:

1 Like

Thanks @robles !

For me the dual monitor is more important than the collapsed tools. But I would assume that this issue will be fixed. Thanks to all who are working on RT!


I only use a single-monitor setup, myself, so I’ve never needed to change this setting from default; as such, I’ve no idea if the persistence of such preferences are disabled intentionally when doing so. Having said this, I’m sure that the details would be documented in RawPedia if this was the case.

If it’s definitely a bug, it would certainly be worth filing a bug report (if one doesn’t already exist) so that the issue can can be investigated and hopefully fixed.