How to make Nautilus/Gnome show RAW thumbnails.

No matter what I do I can’t get thumbnail previews of my RAW files in Nautilus.

I’ve tried installing libopenraw7 libopenrawgnome7, I’ve tried edditing /usr/share/thumbnailers/ufraw.thumbnailer to add all known RAW extension types. I tried nautilus -q and rm -rf ~/.cache/thumbnails/*, I set it in Nautilus’ preferences that it should preview thumbnails for all files under 4096MB, but nothing works.

Any other ideas?

I’m not surer if this will work but it might get you on the right path. I did a search in Synaptic Package Manager using “thumbnail” and found this “gnome-raw-thumbnailer” in the list. Also, I did a search online using “raw thumbnails in linux” and found this.
Hope this helps!

Using synaptic I can’t find any gnome-raw-thumbnailer.

I’m using ubuntu studio 18.04. I don’t know how to tell which repository it is in.

I have the same problem, but with most video thumbnails.
If someone could give me a hint what to install for Nautilus on CentOS 7, that would be great.

Did you check the Nautilus preferences, there the preview configuration?

Yes. It’s on “all files - On”
Also as everything else.

That’s actually the first thing I did, I set it so that it previews any file smaller than 4096MB.

However, I just noticed something strange. I just copied a fresh batch of RAWs from my SD card and sure enough, all thumbnails are displayed correctly, but not those that were already on my hard disk.

So I’m led to belive it’s something to do with the thumbnail cache. Why then, doesn’t rm -rf ~/.cache/thumbnails/* make Nautilus believe all my RAWs are new and display their thumbnails?

I still haven’t managed to get to the bottom of this, however I noticed newly copied raw files (new as in after I added all the missing MIME types to /usr/share/thumbnailers/ufraw.thumbnailer) all correctly display their thumbnails, but not those that I copied to my drive before said edit.