hsv2rgb example image doesn't fit to the result from the G'MIC

If I run the code from the hsv2rgb example I don’t get the same result then the example image:
gmic (0,360;0,360^0,0;1,1^1,1;1,1) resize 400,400,1,3,3 hsv2rgb

@David_Tschumperle I think you should change the image or the code here.

This is because you are assuming that you can copy/paste directly the G’MIC command to a shell, append gmic to the front, and it will run as expected.
This is not true.

The shell has its own substitution mechanism and in this case, does something to the command that change it in a way it is still a valid G’MIC command, but renders something else.

To be sure you run the ‘real’ G’MIC command, the best is to copy/paste the command in your user.gmic command file, e.g.

foo : 
  (0,360;0,360^0,0;1,1^1,1;1,1) resize 400,400,1,3,3 hsv2rgb

then try $ gmic foo from your shell.
Doing this renders exactly the same image as in the documentation, for me.

EDIT Trying the command directly on my shell (bash), I even get a syntax error:

$ gmic (0,360;0,360^0,0;1,1^1,1;1,1) resize 400,400,1,3,3 hsv2rgb
bash: syntax error near unexpected token `0,360'
1 Like

You are of course absolutely right. I used btw. the windows shell.

Now I have discovered the next problem, the images at the end of this page are all broken:


  1. The example " $ gmic -input example.png -circlism 2,5 -display" is broken because “circlism” is not found.

  2. It looks like all images in the tutorial section are broken

  3. You still link to the [G’MIC at Google+] page, that no longer exists.