I am very very slow with Natron


I have a very slow problem with Natron.
Novice in the field of Natron, I am nevertheless a Cinelerra user with some experience. I downloaded Natron for Ubuntu and tested 2 versions, the snap 2.4.1 and on the site the 2.4.3. My system is ryzen 7 + 16gb ram + m.2 evo 870 ssd with ubuntu studio usable in performance mode.
I can import and work with very small videos of maximum 200 frames. For example if I import a 30 second mp4 video which is 1987 frames long, i.e. 33 seconds, it is almost impossible to play it in the viewer. It would take 1 or 2 hours to do the pre-reading!

I thought my computer is not powerful enough when I tried the demo version of Nuke and with Nuke it works fine with my 33 second clip. I can manipulate it, apply nodes, view them in real time and the video plays smoothly in the viewer.

That’s why I tell myself that there must be a basic setting problem in my version of Natron? Could you help me find solutions?

Many thanks in advance, best regards


Natron is a compositor, not a video editor. So you should not expect real-time playback in any way (yes, Nuke can do it, but it has more NLE features these days than before).

One more thing, Natron loves RAM. I would say 32GB is a minimum for a usable viewer experience (excluding CPU power needed to go through the nodegraph).

I recommend you convert your video footage to image sequence (EXR or TIF). This will improve performance quite a bit.

Thank you very much for your help, I understand better. I will work with image sequences.

I will change my ram, do you think 32 Go is enough or 64 Go will be really use ?

You don’t need to change RAM yet, try with images first and see if that improves.

I converted my example video mp4 to 1988 frames like tif. I imported all of this into a player in Natron and it works fine now to play it in real time. But I keep having problems. To do some tests I created a project which contains a player with the whole tif sequence + a shadertoy (source=Flaring) which go into a Merge node then into “write” to produce an mp4 file.
First Natron crashed. I then deselected “Enable GPU Render” in shadertoy. Then in “Write” I had to select RGB instead of YUV420 or UV422 (if not crashesd) and finally I was able to render but it took more than 60 minutes!

I reproduced exactly the same experience in my yoga 720 laptop (i7-7550U cpu + 8 GB ram + Intel HD Graphics 620 + ssd m.2) and it works perfectly. Rendering took about 5 minutes. Then I added a second shadertoy with a second merge and it took about 8 minutes to render perfectly.

So maybe it could come from my nvidia geforce 630 graphics card in my pc ?

Configuration level my pc should work as well as the laptop since it is a little more powerful?


In the end I solved the problem and I hope it can help other users too.
So in fact I realized that my Ubuntu system was installed with the X.org drivers and did not offer any possible alternative in the dedicated window that I usually used in synaptic. But I found in the repositories the proprietary driver that I was able to install. For my graphics card it is nvidia-driver-390. Now everything works perfectly and Natron is very smooth. I can do a lot of things and the renderings, even large ones, are fast with durations of only a few minutes. I guess my renders for Cinelerra which used to take hours are also going to be much improved…
As I do more and more editing and I intend to use Natron in addition to Cinelerra, I ordered 32 GB of ram to improve my system and be quiet. I go from 8 GB of ram at 3000 Hz to 32 GB at 3200 Hz.
Thank you in any case for your help because without it I think I could have given up before solving my problem. Natron is really great software !

1 Like

Hello @chapolin , I spotted your thread because I am also using Cinelerra, & using image sequences ( & video as well) and plan on trying Natron down the road. Unfortunately my AMD system (Phenom II x965, 12 Gigs DDR RAM) and graphics card are way older, thus slower. I am using the Nvidia binary 340 driver (geforce gts250).

I am curious if you got around to using Cinelerra since then & if you use TIFF sequences from TOC, do you use RGBA & Jpeg in settings & x11 & open GL for the video player? Are your images rendered to sRGB to match Cinelerra’s Compositor or do you use other colourspace like rec709?