I cant move layers and put them into groups

I have very recently started using gimp and I have been getting used to it, but I cant move the layers by holding LMB them and moving them which means I cannot put them into groups :sob: I would really appreciate some help!

I have never worked with layer groups, but I looked up the online user guide and followed the instructions there and all worked as I would expect. I create a new layer group and then dragged and dropped layers into that group.


But you say you can’t left click to drag and drop. Can you drag a layer to the red cross at the bottom of the layers dialog to delete that layer?

Possibly something interfering with the mouse, especially on Windows: “security” software, desktop enhancers, screen recorders…

Can you at least move the layers using the Layer > Stack menu entries or the ʌ v icons at the bottom of the layers list?

It is most likely one of those issues that Ofnuts mentioned. I remember one user, that using Windows and an Nvidia screen utility which stopped click-n-grab.

Unlikely, but if it is just a case of say, a 4K display and tiny icons then use the layer dock drop-down menu and increase the icon size, it might help.


Regardless of that, it is tedious to click-n-drag layers into a layer group and there are utilities to help. Two in this zip: group-utilities.zip (2.9 KB)

An old one, but the one I use, is a script-fu sg-group-linked-layers.scm It also combines an “ungroup” as well.

More recent, a python plug-in move_visible_layers_to_layer_group.py Not for me but worth a try.

Using either of those, make sure you know how to toggle on/off those visiblility and link icons. Of course, if you can not click anything in the layer dock that might not be possible and you need to go back and find the source of the problem.