I did something stupid... help! [solved]

I’ve spent my Sunday afternoon installing Q4os (Debian with KDE Plasma for most intents and purposes I think) on my old laptop, replacing the increasingly sluggish Win10.

All went well, until casting around for a way to hook my wifi printer I installed rdnssd (using apt) thinking I needed it to run ‘something’ to find my printer.

I didn’t realize it would remove network-manager… so I removed it again. But now I have no network connectivity at all. So I can’t install anything! :rofl:
I’m in a kind of catch-22 situation, all through my own careless attitude.
I could reinstall the OS, but seems a waste if there’s a more reasonable approach to fix it.

Any suggestions anyone?

1 Like


$ ip a show | awk  '/^[0-9]: /{print $2}'

got me the name of the usb ethernet adaptor, then sudo dhclient eth0 with the eth0 replaced with my adaptor got internet working.
I still haven’t got network manager running properly yet, but I’m sure I’ll work it out…

1 Like

Yep. Sudo apt-get install plasma-nm was the missing bit.

1 Like

You can also configure your interface by editing /etc/network/interfaces

When I installed debian on my server it came without network manager and I got network by configuring it. Since I needed a static IP it worked out well and it’s what I use to this day.

After configuration you need to bring the interface up with ifup

auto lo
iface lo inet loopback

auto eno1
iface eno1 inet static
1 Like

Thanks! I saw some advice online on a forum somewhere on that approach. I found it a little hard to get my head around, but was going to try it.
Then came across the dhclient thing, tried it hopefully and it worked. :slight_smile:

I still need to get the printer (an Epson on wifi - uses a proprietary app on Windows) sorted, but I’ll read up more carefully this time instead of my previous “click first, ask questions later” approach :expressionless:.

1 Like

Many years ago at work we used Network Manager for dynamic environments (like a laptop) that need to leave and join networks in a regular basis. But we used @hatsnp’s method for static installations such as servers (all the /etc/sysconfig/network scripts, if memory serves).

Then again that was on RHEL, was many years ago and I’ve probably forgotten half of it. I once “cloned” a server OS by letting a newly installed drive hardware-mirror to another then modifying the mirror for a second server. It worked but took a slight lobotomy to the network config before it was done.

1 Like