I'm unable to draw lines

Hello, I’m a relative newbie to GIMP.

I’m having the problem of being unable to draw lines, pencil or brush, on a photo. I’m trying to make an overlay map on a photo of the area where I live. For some reason, I’m unable to use the pencil or brush tools to draw lines. This was happening in version 2.10.32 too.

I tried updating from version 2.10.32 to 2.10.34. I tried uninstalling and reinstalling the program.

This is a multiple-layer map. Am I limited in the number of layers I can use? I have drawn on the layer I’m working on, but then I stopped being able to draw lines.

GIMP 2.10.34
Windows 10 Pro 64-bit


Be sure you are on the image part of the layer… sometimes its possible to select the mask accidentally.

of being unable to draw lines

Is this because:

  • you can’t find/start a tool that does this?
  • you get a “forbidden” sign when using the tool
  • there is no mark when you draw
  • other

Also, see this checklist.

Otherwise, can you show a screenshot of the UI with Layers list and tool options visible?

1 Like

I draw lines all the time in GIMP. We will be able to help you if you share the information requested by others.

Thanks, Ofnuts, for the link to the checklist. I had an area selected in the image.
Once I cleared the selection, I was able to draw lines again.

Thanks for your help, people, it’s much appreciated. Here’s a little of the image I’m working on.


It’s just a rough map.

That’s something I would do with Inkscape and not with GIMP. I think that’s the better tool for this task.

1 Like

I agree, and more easy with inkscape