Inkscape 1.0 is out

And they did a fantastic video showing the news:


What! Thanks for sharing.

Big news…thanks for sharing.

I wonder if we should reach out to Chris Rogers (CR) if he could help out with promo videos and other design stuff in other, more photography centric, projects as well :innocent:. This video is one if not the best promo video I ever saw.


Indeed, it makes Inkscape look sleeker than I know it is. :slight_smile: The constant angle changes gave me motion sickness, but that is just me.

1 Like

Hm, I tried 1.0 out today and it makes a much sleeker first try than earlier versions. Much more polished. But time lapse etc. of course contribute to this feeling in the video.

Yes, it is, and so far, we’ve been unable to download and update it on FossHub for almost 24 hours. We tried to offer a download mirror but no replies so far (via Twitter). We can serve any amount of traffic and replicate the files worldwide instantly, so if anyone knows the Inkscape team, please let them know.

Update: We managed to update it to version 1.0, if there’s anyone not being able to download from them (for example it took me 30 minutes to download the macOS version) you can download InkScape from FossHub project page.

1 Like

Thanks for the information. I just found out that I had the new version for three day (archlinux) :wink: .

1 Like

Congratulations!!! :star_struck: Cheers! :clap: :clap: :clap:

Very nice promo vid. Thanks for sharing.

So glad you said. I’ve probably got it too, then. :slight_smile:

Cool video, but I don’t want to mess up my Voroinoi Stipper which uses the python in Inkscape (I know; should have split out the path a long time ago). lol


I finally upgraded. The glaring issue for me right away is that the icons and toolbars are too large. I resized the icons via Interface, but only the left toolbar changes. If I set the toolbar view to custom, the view port only fills half of the screen. :sob:

PS Guess I will downgrade for now. Hmm… lots of Windows registry entries to delete manually.

Maybe give RevoUninstaller a try. It can log the registry leftovers after uninstalling.

No worries. I good at removing them. Just wished the portable kept its settings in the folder I installed it in.