Input profile checkboxes greyed out in recent RT?

The RT auto matched profile for my camera Pentax K-1 always had a DCP look table with over saturated colours (fine with look table disabled). These checkboxes are greyed out with recent builds and I’m wondering if something changed in RT or if I’ve wrecked something. New Pentax K-1 dcp? To my eyes the images now look over saturated. I’ve looked at recent commit messages and haven’t found anything that appears to touch this stuff?

2022-07-23-113719_498x422_scrot

Can anyone explain or guess what I’ve broken?

build info

Version: 5.8-3257-ga61f0733b
Branch: dev
Commit: a61f0733b
Commit date: 2022-07-23
Compiler: cc 11.3.0
Processor: x86_64
System: Linux
Bit depth: 64 bits
Gtkmm: V3.24.6
Lensfun: V0.3.3.0
Build type: release
Build flags: -std=c++11 -Wno-deprecated-declarations -Wno-unused-result -O3 -msse2 -std=c++11 -fno-tree-loop-vectorize -march=native -Werror=unused-label -Werror=delete-incomplete -fno-math-errno -Wno-attributes -flto -Wall -Wuninitialized -Wcast-qual -Wno-deprecated-declarations -Wno-unused-result -Wunused-macros -fopenmp -Werror=unknown-pragmas -O3 -DNDEBUG -ftree-vectorize
Link flags:  -march=native -flto
OpenMP support: ON
MMAP support: ON
Build OS: Linux 5.18.0-2-amd64 x86_64
Build date: Sat, 23 Jul 2022 09:25:05 +0000 UTC
Build epoch: 1658568305
Build UUID:

Can you check whether a “RICOH PENTAX K-1.dcp” file exists in your RawTherapee\dcpprofiles folder, and whether this exact camera name is shown in RawTherapee when opening your file?

'./dcpprofiles/RICOH PENTAX K-1.dcp'

Which is the same as the various camera strings in RT. I also think that, unless behaviour has changed, the “auto matched” option would be greyed out in the Colour Management section if no dcp has been found in the RT dpprofiles directory. My issue is the dcp sub options being unavailable seemingly forcing the look table.

The check boxes are there when specifying a separate Adobe dcp though
2022-07-23-133550_507x545_scrot

I checked with files from various common cameras in my dwn folder and none enable the dcp check boxes. D500, D7100, 5DM3 etc. I know that the dcp has to have the settings but I don’t know how to quickly check for look table in a dcp.

Does it work for anyone else or are the checkboxes always grey? If it’s just me I’ll just nuke my rt source folder and recompile.

I remembered that my Ricoh GR II lacks RT colour profile so I checked what the dialogue looked like. The “auto matched” checkbox is indeed greyed out when no rt dcp can be found. Did a git log on the K-1 dcp and it hasn’t changed since 2018

2022-07-23-151309_507x639_scrot

git log rtdata/dcpprofiles/RICOH\ PENTAX\ K-1.dcp

commit 93cfc231b65f63c104dfaa7f71132f0bd3fcff12
Author: Morgan Hardwood <bugs@londonlight.org>
Date:   Sat Apr 14 19:51:23 2018 +0200

    Updated RICOH PENTAX K-1 dual-illuminant DCP

commit 283b37f3908ad3e86cc8e169e5c549885c60c613
Author: Morgan Hardwood <bugs@londonlight.org>
Date:   Sun Mar 11 17:26:49 2018 +0100

    Updated dual-illuminant RICOH PENTAX K-1

    Red and blue anti-magenta tweaks.

commit a14e48ba9304401ed240a8f322a765aee8315ebf
Author: Morgan Hardwood <bugs@londonlight.org>
Date:   Thu Jan 19 00:40:36 2017 +0100

    Added RICOH PENTAX K-1 dual-illuminant DCP, no issue, raw files from Hombre

To me this suggests others should be seeing the same issue with their rt dcp’s. Someone who knows their camera should have a look table and tone curve should check with a recent build to see if it works.

Hello @nosle, I have 5.8-3104-gdd0054918 as latest commit from dev source RT git repo https://github.com/Beep6581/RawTherapee. You list a different build. This might not be related to your issues though.

Regrading this:

This is what I get with Canon 5D mk IV and CR2 raw files on latest dev build (from source on Debian Linux, 5.8-3104-gdd0054918):
Screenshot from 2022-07-23 15-47-56

Thanks for testing. I downloaded a 5Dmk IV file from here
https://www.dpreview.com/sample-galleries/9485291827/canon-eos-5d-mark-iv-sample-gallery/3513122343

and it looks like this
2022-07-23-160107_496x466_scrot

Deciphering the theme differences it must be an error on my part. Thanks again!

hello again @nosle. I tried Canon EOS 5D Mark IV Sample Gallery: Digital Photography Review as well. I get the same result as before Input profile checkboxes greyed out in recent RT? - #5 by KarlMagnusLarsson.

Wiping and cloning afresh solved the issue. I must have done something along the way!

I spoke to soon! Using the above dpreview sample image Canon EOS 5D Mark IV Sample Gallery: Digital Photography Review the checkboxes are enabled when opening the file.

However, if I change to “Camera Standard” and then back to “Auto-matched” the options are greyed out again. Beyond that I now notice that your screenshot has checked but disabled Look table and Baseline exposure. These should be optional right?

I can get the selectable Base table checkbox back by ensuring Auto-matched is enabled and then switching back and forth to another image. Look table however is never enabled.

Same for me.

Same for me.

I do not know if Look table and Baseline exposure should be optional or not for my Canon 5D mk IV and my lenses. I guess this depends on what is in the DCP profile.

Edit: I get different behavior for different lenses. My lenses behave like this on my Canon 5D mk IV:

  • Canon EF 24-70 mm f/2.8 L, Canon EF 85 mm f/1.2 L, Canon EF 135 mm f/2.0 L have DCP ‘Tone curve’ empty and grayed out, ‘Base Table’ with checked box (active), ‘Look table’ and ‘Baseline exposure’ have checked boxes, but are greyed out.

  • Canon MP-E 65 mm 1x-5x macro looks like my other lenses, but has DCP ‘Look table’ empty (no check mark) and grayed out.

What is the intended and correct GUI behavior for these cases?

I always leave ‘Color tab’ → ‘Color Management’ to ‘Auto-matched camera profile’ and never touch DCP settings. I am using whatever defaults in ‘Bundled profiles’ → ‘Auto matched curve ISO low’. This means that I am uncertain what is intended here.

I’m pretty sure what lens you have mounted should not affect the input profile options! The available options should be determined by the contents of the profile. A look table for instance is as far as I understand an optional part of the dcp. Not all will have it and it’s meant to provide a look on top of the “correct” colours of the base table.

Until recently the behaviour with RT and the Pentax K-1 was that the checkboxes (I think all of them) were active and resulted in visible changes to the image. Nothing you did elsewhere in the software would change the available options. They just reflected the available dcp.

I’we now also temporarily moved my .config/Rawtherapee folder to let RT create it afresh. Same strange behaviour as before.

I’ve dived further into this and it’s some kind of gui issue. When first opening a file set to auto-matched the check boxes are available as expected and can be switched on and off at will. Using other tools have no impact and returning to colour management the check boxes are still available.

  1. The input profile dcp options are only available if auto-matched profile was set when the file is opened.
  2. If you change away from auto-matched the dcp options will be greyed out when you select it again.
  3. By setting auto-matched then switching to another image and back the dcp options will be active again until you select another type of input profile.
  4. A pp3 profile setting auto-matched will also enable the checkboxes when applied

I did a random checkout of RT git repo dev branch g22f5a90cb, May 31 2021, from more than a year ago, then this issue is not present:

I can change between ‘Camera standard’ and ‘Auto-matched’ using g22f5a90cb, May 31 2021 code. The options do not become greyed out when changing options.

Edit: 89492228b from Feb 4 07:36:19 2022 works. I will try and bisect from here.

Hello @nosle and @Lawrence37

I have bisected this issue described below by @nosle and in this thread (above) and it points to commit 37080e1b5 Fix some history messages (#6474) · Beep6581/RawTherapee@37080e1 · GitHub

Issue:
In current RT dev git repo starting with ‘Color tab’ | ‘Auto-matched profile’ selected having DCP ‘base table’ as an active option and then selecting ‘camera standard’ will leave DCP options grayed out and inactive, even when going back to ‘Auto-matched profile’. This happens despite the fact that the camera has a ‘base table’. Selecting a new picture and going back will make DCP options possible to select again. (My case Canon 5D mk IV camera).

‘Auto-matched profile’ selected (default in ‘Bundled profiles’ → ‘Auto matched curve ISO low’):
Screenshot from 2022-07-23 23-11-03

Selecting ‘camera standard’ and then back to ‘Auto-matched camera profile’ will make DCP options grayed out in GUI until selecting another raw file and going back.

Screenshot from 2022-07-23 23-15-10

This is what git bisect showed:

git bisect good

37080e1b5d12a4e128d73c7011ef6e97f8df1ec7 is the first bad commit
commit 37080e1b5d12a4e128d73c7011ef6e97f8df1ec7
Author: Lawrence37 <45837045+Lawrence37@users.noreply.github.com>
Date:   Fri May 13 20:39:31 2022 -0700

    Fix some history messages (#6474)
    
    Use correct key for spot removal history message.
    
    Remove B&W channel mixer auto enabled message when changing the filter
    color.
    
    Replace hard-coded input color profile strings.

 rtgui/blackwhite.cc |  1 -
 rtgui/icmpanel.cc   | 12 ++++++------
 rtgui/spot.cc       |  4 ++--
 3 files changed, 8 insertions(+), 9 deletions(-)

The commit before this works: feada4cd0

1 Like

Fixing this right now…

2 Likes

Issue: https://github.com/Beep6581/RawTherapee/issues/6533

1 Like

Should be working now.

Hello @Lawrence37 and @nosle,

Thank you @Lawrence37. The commit works for me (Fix incomplete changing of input profile · Beep6581/RawTherapee@262d00b · GitHub). I can move between ‘Color tab’ | ‘Auto-matched profile’ and ‘camera standard’ and the GUI stays active, it is not grayed out.

A question for my understanding and learning:

What is the intention with ‘Color tab’ | ‘Color Management’ | ‘DCP’ syntax in GUI? For my Canon 5D mk IV ‘Auto-matched camera profile’ I get this:

Screenshot from 2022-07-23 23-11-03

From ‘DCP’ I have ‘Base table’ as active and possible to deselect.
‘Look table’ and ‘Baseline exposure’ have tick marks but are greyed out.
‘Tone curve’ is empty.

My interpretation is that this indicates that:

  1. There is no ‘Tone curve’ at all in DCP file for Canon 5D mk IV.

  2. I have a ‘base table’ in DCP file for my camera with the option to use it or not and the default is to use it.

  3. ‘Look table’ and ‘Baseline exposure’ exist in DCP file for my camera and they both have to be selected with no option to deselect , because not selecting them leads to obvious errors in color management.

I am curious to know what is the GUI trying to tell me?

Are these active and greyed out tick boxes there by design, because other choices are outright wrong, or is this simply a sign that ‘Canon EOS 5D Mark IV.dcp’ contains certain tables and does not have some other tables, or something else, like side effects of GUI code.

I am aware of Color Management - RawPedia section. There is a lot of info there about DCP files, but I understand it is impossible to fit all details.

Good questions!

There’s another GUI uncertainty with this module. When using ‘camera standard’ there’s no way of knowing which of the many profiles this option covers is actually active.