Install on opensuse leap 15.2 crash

opensuse leap 15.2 (current version for leap)

froggy@ethelbert:~> cd ~/vp3; source bin/activate       
(vp3) froggy@ethelbert:~/vp3> cd ~/downloads/rpms/

I’m using a python virtual environment

(vp3) froggy@ethelbert:~/downloads/rpms> python3
Do you want to install Rapid Photo Downloader into the current virtual environment?  [Y/n] 
Using virtual environment for installation using pip.
Detected Linux distribution openSUSE 15.2

Downloading (8.21 MB)
Downloading.... done!
Querying zypper to see if any required packages are already installed (this may take a while)... 
To continue, some packages required to run the application will be installed.

The following command will be run:

sudo /usr/bin/zypper install -y zeromq-devel python3-devel libraw-devel gcc-c++ rpm-build intltool zenity gobject-introspection-devel python3-cairo-devel git libgphoto2-devel libmediainfo0 typelib-1_0-UnityExtras-7_0 typelib-1_0-Unity-7_0 typelib-1_0-Dbusmenu-0_4 typelib-1_0-Dee-1_0

sudo may prompt you for the sudo password.

[sudo] password for root: 
Retrieving repository 'packman' metadata .................................................[done]
Building repository 'packman' cache ......................................................[done]
Loading repository data...
Reading installed packages...
Resolving package dependencies...
2 Problems:
Problem: libgphoto2-devel-2.5.18-lp152.2.7.x86_64 requires libgphoto2-6 = 2.5.18, but this requirement cannot be provided
Problem: python3-cairo-devel-1.15.1-lp152.4.5.x86_64 requires python3-cairo = 1.15.1, but this requirement cannot be provided

Problem: libgphoto2-devel-2.5.18-lp152.2.7.x86_64 requires libgphoto2-6 = 2.5.18, but this requirement cannot be provided
  not installable providers: libgphoto2-6-2.5.18-lp152.2.7.x86_64[repo-oss]
 Solution 1: Following actions will be done:
  downgrade of libgphoto2-6-2.5.26-lp152.228.1.x86_64 to libgphoto2-6-2.5.18-lp152.2.7.x86_64
  install libgphoto2-6-2.5.18-lp152.2.7.x86_64 (with vendor change)
    obs://  -->  openSUSE
  downgrade of libgphoto2-6-lang-2.5.26-lp152.228.1.noarch to libgphoto2-6-lang-2.5.18-lp152.2.7.noarch
  install libgphoto2-6-lang-2.5.18-lp152.2.7.noarch (with vendor change)
    obs://  -->  openSUSE
 Solution 2: do not install libgphoto2-devel-2.5.18-lp152.2.7.x86_64
 Solution 3: break libgphoto2-devel-2.5.18-lp152.2.7.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c/d/?] (c): c
Command failed

I didn’t select anything and I didn’t type C for cancel, the script did.

Any suggestion on what I should do?


you can always get the latest package from

an older version is even included in the normal distro repository.

Thank you

I just tested the script on an up-to-date version of openSUSE Leap 15.2 and it worked. I don’t know what is causing the package conflicts on your system.

Thank you

Syv mixed different repositories and zypper asks now “which should i pick because I have to move packages around to get a consistent state”

Which packages Syv prefers depends on their choice.

I would be curious about the reason to prefer manual install over the existing packages.

For me, it’s for 3 reasons:

  1. I would have preferred to have in a venv
  2. I didn’t know that it was in the opensuse repos
  3. I wanted the “current” version


ah ok so no problem with the package then. great.