I have been using v3.0.1 on Linux Mint 19.3 for some years. I’d like to get the newer version 4.42 to benefit from its features but dont want to wipe my system with newest version of Mint.
I’ve tried installing the Deb package and I keep getting "Error: Depenancy is not satisfiable. Libc6 (>= 2.35). I have libc6 v2.27-3.
I realise I cant update libc from Mint repositories anymore due to its age. But just curious if there was another way I could use Darktable 4 on this system? Or any tricks to get libc updated despite it being at its max update cycle in my distribution.
If you want to keep a system that old, you’re best off trying the flatpak.
Will flatpak even run mint 19.3 (Ubuntu 18.04)?
Oh that’s how old that is? Maybe? Better to just upgrade.
I believe newer versions of Mint don’t need a complete wipe-and-reinstall procedure. But anyway, next time you do wipe your system, partition it so that root (/) is separate from /home; that way, an upgrade or complete distro switch is less of a hassle.
You could install Ubuntu with Cinnamon or with MATE, and do a trivial, in-place upgrade whenever needed (I do it whenever there’s a new version, so every six months).
Thanks all. Took the plunge with the phased upgrade route via mintupgrade tools as suggested. Gone from 19.3 to 20.0, to 201., to 20.2, to 20.3, and now going to 21.0. So far so good. So will get the latest DT once complete. Was just trying to avoid several days of upgrading and tweaking.
there is a simple solution to avoid days of upgrading:
upgrade when ever a new version comes out
True…but not always that straight forward on business production setups. It turned out, the upgrade to 21 didnt go to plan - my 1.5Tb LVM drive is now inaccessible!! So now I have to reconfigure all that and restore from backups probably This is why I didn’t want to upgrade.
Update : i got there in the end (my LVM RAID needs to be “poked” by partprobe on Mint 21 but once I do that I can mount it and access all the data), and have the latest version of Darktable running on Mint 21. Hooray. Thanks for the nudge guys - got me to do what I’ve been putting off for a while.
I’m on Linux Mint 21.3 Virginia and I get the same error when trying to install 4.6 from OBS Ubuntu version
In other words my installed version of libc6 is too recent.
I don’t know about your version of libc6, but in the message you quoted, the installed version was too old (installed: 2.27, required at least 2.35)
Sorry, I was just quoting the original poster.
My situation is:
dpkg -s libc6 gives : Version: 2.35-0ubuntu3.6
GDebi Installer error:
" Dependency is not satisfiable: libc6 (>=2.38) "
That is, I need 2.38 but the latest Mint release only supports 2.35
Flatpak will let you install it.