Installing GMIC under windows 10


(Robert Davis) #1

I am having a great deal of trouble install this plugin on Windows 10. I have downloaded both the 32bit and 64bit msi files and zips.

I have installed Gimp 2.8.20 in a custom folder of my own making. I have had it there on this machine for months and all other plugins and .scm files seem to work.
The directory is “C:\Users<User Name>\Desktop\Blender Files\GIMP 2”

The plugins folder under that is : “C:\Users<My User Name>\Desktop\Blender Files\GIMP 2\lib\gimp\2.0\plug-ins”

the 32bit version of the GMIC installer seems to want to put the files in “C:\Users<My User Name>.gimp-2.8\plug-ins\gmic_gimp_qt”

I have tried using the .msi with its proposed folder and GMIC does not show up inside of gimp
I then tried unzipping the 32 bit zip foder “gmic-gimp-qt-2.2.1-win32” to “C:\Users<My User Name>\Desktop\Blender Files\GIMP 2\lib\gimp\2.0\plug-ins” That produed and error dialog saying “The application was not able to start correctly (0xc000007b). Click ok to close the application”

Is there a way to install GMIC under the gimp plugin folder that strong text Istrong text want and if not how do I install it so that I do not have to uninstall gimp from the location that is is saved and reinstall it where THIS plugin thinks it should be ?


(samj) #2

@Shaba1

Video :


(Robert Davis) #3

samj: I have already viewed that video and followed it. I got the same results that I orignally posted.
But that link does not answer my actual question. See below


(Pat David) #4

The best way to handle this is to unzip the G’MIC files into whatever folder you’d want. Then tell GIMP where to find it.


(Robert Davis) #5

patdavid: I have just down that. I tried using the 32 bit msi under my main gimp directory. that did not work. I tried using the 32 bit msi and letting it use its default directory after deleting the one that I had made. I have tried using the 64bit msi and installing in the default directory. Every time I used the gimp preferences dialog to add that directory to the plugins dialog. Either I get nothing in the filters menu OR I get that popup dialog that says the app will be closed.

I just give up. I think you guys have made a GREAT plugin but it should not be this hard to install or require me to change operating systems to do it.


(Mica) #6

are you sure your pointed gimp to the right directory?


(Robert Davis) #7

Yes I am sure. I keep getting the following dialog box


(samj) #8

@Shaba1

Try to decompress the G’MIC archive into a directory whose name does not contain accented characters or spaces.
Use the 64 bit archive.

:o)


(Lisa Golladay) #9

I tell you true. I have given up trying to install or update the G’MIC plugin on Windows for an existing GIMP installation. So many error messages. A couple of years ago I thought I finally had it figured out. I updated G’MIC with no problems, several times in a row. Eureka! But then came another apparently routine G’MIC update that broke GIMP. Apparently I had not been updating GIMP frequently enough to stay ahead of the G’MIC updates and all those darling beloved .dll files.

So I had a choice. Devote a fair amount of time to keeping all my software updated all the time. Or spend that time taking photographs and editing them. I enjoy photography as a hobby. I do not enjoy coding or debugging or computer maintenance.

My solution, which might or might not work for you but it’s just a suggestion, is to keep two instances of GIMP on my computer. I have a version of GIMP 2.8 that I have frozen. No updates to it or to G’MIC. It is the software I use when I have work to do because I know it won’t crash on me and require an entire afternoon of debugging to get it running again.

But since I do enjoy playing with new software tools, I periodically go to Partha’s website (partha.com) and download the portable version of his latest 2.9 build for Windows. It has G’MIC already installed. It works perfectly but I try not to get too attached, because soon I will replace it with a newer build. I’m looking forward to Partha’s first 2.10 build.

I don’t intend any of this to read like a complaint. There is no way I am going to complain about nice talented people making brilliant software available for free. I am grateful to the G’MIC team and the GIMP team. But let’s be honest, sometimes it’s a royal bear to get the G’MIC plugin installed successfully on Windows. With help from Partha, end users like me (and maybe the OP as well) can enjoy the software with fewer headaches.


(Robert Davis) #10

samj: That last response about unzipping to a directory without spaces and using the 64 bit version FINALLY worked!!!. WHEW. Thank you. I finally put the GMIC folder in my root C;\ directory which I always hate to do with any software but that made it work. BTW I know this is not your responsibility but is there anyway of telling if you have the 64bit or 32 bit version of GIMP other then noticing it when you install gimp For me that and maybe the directory with spaces was the problem.****
Also when I tried to update the GMIC filters form the interface I got this error dialog
capture_011_28032018_150031
So I think either the address in GMIC is wrong or the site is down.


#11

As I would always recommend and @Acmespaceship hinted at, try using the build at partha.com; i.e., GIMP 2.10 RC1 64-bit Standard Edition. I generally use the portable version. See—it has a G’MIC that updates properly!

image


(samj) #12

Bonjour,

@Shaba1
I recommend you download this version of G’MIC GIMP :
http://gmic.eu/files/prerelease_windows/gmic_gimp_qt_win64.zip
The update works well with this version.
Tell me if it works on your computer.

@afre
The 2 versions of Gimp (gimp.org and Partha) are complementary but unfortunately neither is perfect or complete.
I hope with all my heart that it will be possible to do something better with Gimp 2.10

:o)


(Robert Davis) #13

samj: Thanks for all the help. I have gmic working now. As I said I unzipped the 64 bit zip to my root C:\ directory. I get 377 filters. Which is probably more than I will ever need. I tried the link at http://gmic.eu/files/prerelease_windows/gmic_gimp_qt_win64.zip
four times but the transfer would get stuck at 3.5 mb or 0.2 mb and then abort.


#14

If you hit the refresh button, you will have about 500 filters.
My example shows more filters, because I have some duplicates I experiment with.


(samj) #15

@Shaba1

Bonjour,

If you wish, you can try this latest version which includes G’MIC :

You have to use 7-Zip to decompress the archive https://www.7-zip.org/

:o)


(Robert Davis) #16

It must have been my internet connection that was causing the problem. I tried connecting from a different place and got the download within minutes. I extracted the folder to my desktop and renamed it then moved it to the C:\ over top of the present GMIC folder and opened gimp. I checked the internet checkbox and hit the refresh button and now I have 500 filters. Thanks for all the help.