inverted mask covers everything

I noticed the following while working with masks in darktable (screenshots show ellipse masks, but the same happens with drawn masks). Suppose I create a mask for vignetting:

that I invert:

Why does the area inside have a positive mask (note yellow cast)? I found I can make it empty with decreasing mask opacity, it is unclear to me how to make a mask negative without affecting every part of the image.

One thing I can’t see on the screenshots is the feathering radius. Just tried to reproduce and when I push this feathering radius cursor I see the same kind of “positive mask” in the center part.

1 Like

It is 0.

I am curious if others get the same thing if they try it in Darktable.

Check the mask opacity.

Everything is at defaults. Forgot to mention, I am using Darktable 4.8.

For me, on 4.8 it’s working as expected I think…


and inverted

but by hovering over the mask and using ctrl+scroll I can make it look like yours…

I vaguely remember a similar discussion some time ago, but can’t remember the conclusion.

I would say because your mask was not 100% opacity, so when inverted it’s not 100% ‘clear’ to put it clumsily.

1 Like

ctrl+scroll = change mask opacity

1 Like

Perfect! That’s the solution. Can I make 100% opacity default? (for components)

I have had this issue - default masks being less tahan 100 % - some time ago, perhaps I solved it by editing darktablerc. Perhaps this line:

plugins/darkroom/masks/opacity=1,000000

1 Like

Thanks, this solves my problem (I had to use a decimal . instead of a , but maybe this is just my locale setting).

The original value was around 0.55, I am not sure if this is the default, but if it is, I don’t understand why.

The default changes every time if you set mask opacity before creating mask or if you use the ‘mask opacity’ slider in retouch module after the mask is done.

4 Likes

Yes, this is an often overlooked feature.

Note: When used in shape creation mode, the preceding scroll operations will also cause the default feathering or opacity to be changed. The new default values will be used the next time you create a new shape.
darktable 4.6 user manual - drawn masks

The use case for altering the default opacity is described by @elstoc here: Remove plugins/darkroom/masks/opacity from darktablerc · Issue #13037 · darktable-org/darktable · GitHub

I think even though it’s been a recurring issue, we have to respect that different people have different needs. There is a solution, and it is documented. Unless someone can come up with something much better, we just have to remember that is how opacity works in darktable.

1 Like

I just wasn’t aware of the feature but now that I know I understand the reasons. Thanks for everyone who patiently explained to me.

Not that opacity but the drawn shape opacity…sometimes it gets stuck at less than 100 and it looks like that on your screen shot… upper status bar will tell you…

Ignore I missed a post or two scrolling…