Is there a bug with the Quick access module layout?

I’m running Win 11, dt 4.2, OpenCL enabled on a GTX1650.
This is a long standing minor annoyance for me… and I’ve always thought I must be doing something wrong! Maybe I am, but I’d like to get to the bottom of it.
My quick access panel looks like this:

To give an example of the problem, I just decided I’d like the color balance rgb contrast slider on the quick access panel, so I opened the ‘manage module layouts’ window, and added it, then closed the window. Voila, the contrast slider is there, but my sigmoid slider has disappeared. ??
I went back and added it back in again, and that time I think everything stayed put… unless I haven’t noticed something missing.
I’ve had this issue, i.e. seemingly random changes when editing the layout, with various modules, in the quick access panel for ages, but have been too lazy to try find out why. I know 4.0 did it, not sure (can’t remember) about 3.8. I tried a few things like duplicating the saved layout before closing the manager window, but nothing really seems to be reliable.

Any thoughts? Am I doing something silly?

On your screenshot, you have both sigmoid contrast slider and color balance rgb one. On what I read, it’s so not clear which slider disappear. Could you provide a more precise step-by-step (ie: a clear before/after)?

Thus, do you know that you could add/remove settings on quick access panel directly on it (so without opening module manager window). Just use right-click on tab icon and/or modules titles. Do you reproduce your issue there? That could also help to see if your issue is related only to module manager or more quick access panel.

1 Like

Sorry, I was not clear there - it was coincidence I think that the two sliders in question were both contrast! I’ll try again… I added the color bal rgb slider. Doing this made the sigmoid contrast slider disappear. However adding the sigmoid contrast slider at this point seemed to leave the rest intact.

No! I’ll try that and report - thanks.

I tried the adding modules directly, that works well, then I tried to reproduce my issue with a screen recorder running, but annoyingly I can’t reproduce it now. Just before I started the screen recorder, I noticed that the layout preset was set to “last modified layout” instead of my preset. A few minutes before it was set to my preset… I changed it back, and my sigmoid contrast slider disappeared again :flushed:

I’m sorry I’m not able to give better info - I don’t think you have much to go on. I’ll to keep tabs on it and make careful notes next time I change something, so I can give a better description.

That’s the normal behavior : direct change to a configuration is stored in a “temporary” preset, so you can fall back to your preset when you want. If you want to set it as a “normal” preset, just use the preset manager…

For your initial issue, if you manage to reproduce it consistently, may I ask you to open an issue on github ? Thanks !

1 Like

@Nilvus and @AlicVB I was able to reproduce the issue this morning, with the screen recorder running. Would you like to watch it? Just to confirm what I’m seeing, before I head over to Github.
I remove a slider that I added at random when I was testing yesterday, add a vibrance slider, and when I exit the manager, the sigmoid contrast slider vanishes. It’s still not consistent though.

It’s not doing that now… see the screen capture.

ok, that’s clearly a bug :frowning:

What is strange is that in the preset manager, you have 2 colorbalance rgb global chroma entries…
Some questions :

  • does it happen only with this preset ?
  • if you manage to reproduce with other presets, can you check if you have a “double” entry like here ?

and yes, it would be great if you can open a github issue explaining all that ! Thanks !

1 Like

Very strange… I hadn’t noticed that.

Done… Intermittent bug in module manager · Issue #13420 · darktable-org/darktable · GitHub

Just an update for Pixls - I was able to consistently reproduce the behaviour (more or less - see the Github issue) in 4.3+287 (recent weekly windows build).

It’s an odd one…