Is there a fix for Digikam crashing on M1 Macs?

Hi everyone,

Digikam 8.2.0 continuously crashes on my Mac. Whether I am applying a tag or changing the capture date, the software freezes and ultimately crashes. Sometimes, the application stops responding when it’s launching.

I’d love to use Digikam to organize my photo library, but the software feels unusable right now. Is anyone else experiencing this? Is there a fix to make it run smoothly?

Here’s my specs:

  • MacBook Pro Apple M1 Pro Chip w/ 16GB Ram
  • MacOS Sonoma 14.1
  • digikam version 8.2.0
  • Images: 62664
    • GIF: 7
    • HEIC: 57
    • HEIF: 11138
    • JPG: 49893
    • PNG: 496
    • PSD: 84
    • RAW-ARW: 11
    • RAW-CR2: 1
    • RAW-DNG: 159
    • RAW-ORF: 108
    • TIFF: 710
  • Videos: 4321
    • MOV: 4046
    • MP4: 275

Database backend: QSQLITE

I appreciate your help and guidance.

Just out of curiosity, are you running macOS or Asahi linux ?
If the former have you tried the later ?

Mac OS. I’m not a linux user. :slight_smile:

I have the same issue.

It would be nice if you could produce some debug information. Unfortunately, I have no idea how to get that information on Apple computers.

But even then, I’m not sure there are developers for digikam using an M1 Mac. The fee demanded by Apple to be able to sign programs for those machines is rather discouraging for non-paid volunteers. Also, Apple has discouraged certain technologies that were commonly used on other operating systems, meaning that programs using those technologies would have to be specially adapted for Macs (or use stopgaps that might disappear in the future).
tl;dr: Apple is not friendly towards FOSS software…

I am suddenly having the same problem, DigiKam crashes on startup. Strangely I even went back to 8.1 and it is the same behaviour :frowning:

The error report is a bit too long. Any specific section that is needed?

Please post the whole thing. You can attach it as a text file if necessary.

DigiKam Crash report.txt (327.9 KB)

See attached. The interesting thing is when I chose another database / new database, it at least did not chrash, but is not showing any pictures.

It crashes when creating presumably thumbnails in the QImageReader (digikam QImage loader). This will load special files, such as BMP, GIF, AVI, JXL etc.) try to isolate the image file to make it available to us.

I just see it has to be an AVIF image.

Great! Thank you so much - the AVIF image was causing the crash. I deleted it and now it works again :slight_smile: