Is there any way to run ART on wayland?

Hi everyone,
im on beggining of my photo journey, buy apsc cam and searching for some software.
not planning go pro with photos, but after all these years i want some decent travel photos and sometimes i got few nice frames i want to touch and make the most from them (shooting jpeg + raw always - jpegs for collections and raws if there will be something worth the effort)
BUT: im linux user, and dont want to dualboot windows for only few photos a month. The same with mac.
Im using sony camera (apsc) and found out that rawtherapee have best raw encoding for sony right now, and few great thing, but its overwhelming for noob like me. Darktable also dont please me with workflow, so i found that ART thing and it looks not so much easier, but not bloated with everything and looks pretty better int terms of usability.

BUT2: im Fedora user, and wayland is the way unfortunately here for a while.

So question no1: Is art planning go with wayland any time in a future? rawtherapee works just fine so what is the problem?
question no2 if no1 is “no”: is it possible to run this app on wayland anyway?

ART should run just fine on Wayland. It’s just the prebuilt Linux binary that doesn’t work. But if you build it yourself (or use a package from your distribution if that is available) there should be no issue.


What error is it throwing under Wayland? Of coursez with Wayland, you won’t have working color management, but it should run or at least fallback to xwayland.

On Arts website they claim that it is not working under wayland, also there is no art in pkges for fedora (even 3rd party one).

And @paperdigits what You mean color management would not work? in properties (like custom colors for app) or as a feature for editing pohots?

sorry for that kind of silly questions but this is first time i touching photo editing software at all (and specially in linux)

You will not be able to profile your screen using a hardware calibration device and apply the resulting profile.

Ah I was not aware of that. I guess it won’t work then. There is still an appimage if you really want to try it.

Well, as Alberto already mentioned:

NOTE for Linux users: the binary for Linux doesn’t work on Wayland, only on X. If you want to use ART under Wayland, you need to build it yourself.

You can download an archive with ART compiled from latest master on Fedora 36 here.

1 Like

I use Fedora 36 Wayland Gnome, and applied my previously (under F35 X11) generated ICC profile succesfully.

Yes, you did half of what I said. The other half is not possible.

In Fedora 36 you can choose Gnome under X11 when you login.

It is. I tried today after a full system reinstall (F36 Workstation). Calibration is done under Wayland with DisplayCal and ArgyllCMS, hardware: Pantone Huey. Went without errors.

Maybe with xwayland, as DislayCal has hard dependencies on x11.

have any changed recently with ART under wayland?
i using binary which someone send me here, but i loved to just install RPM and have all updates and so on.

if not, have anyone most recent version of it? i feel like i cant build it on my own, i tried and mess things up few times now.


What distribution are you using? Maybe we can try to figure out why you can’t build it, I think this is the best option…


Fedora 36

Thanks. Could you also post the error message you get when compiling? Or even better the whole console output?


Actually i have no idea where to start, as rawtherapee shows how to compile it with fedora under #26
Not sure about dependencies, also removed rawtherapee, and not sure if ART have lens corrections embeded as i cant find anything related.
Please just help me with good step by step for fedora 36 if possible.

Also AppImage wont work too, get this error: “GLib-GIO-ERROR **: Settings schema ‘org.gnome.settings-daemon.plugins.xsettings’ does not contain a key named ‘antialiasing’”

Is there any chance that add ART to RPM repository or FLATPAK? it would be great to maintain updates, and im sure there is lot fedora users here.

thank You

That also shows up on Ubuntu if you try to run the ART AppImage on Wayland. And it goes away if you switch to Xorg.

See agriggio / ART / issues / #249 - GLib-GIO-ERROR on Ubuntu 22.04 — Bitbucket

And here’s how to switch Fedora to Xorg:

Can you try running the latest Linux binary release like this?

Does this work?

Sorry for late update, but im really busy recently.
@elGordo i dont want to switch to X and want my system to work with wayland.
@agriggio is it possible to run art with x11 and still use a wayland as default? If not, is it even possible to run it on Wayland? i think it is, as i got once appimage which works (when i was testing in VM) but now i cant make it run for me.
And secound tought - the GTK_BACKEND makes only art running with X11? sorry, im linux user, but apparently never doing any of this stuff.

thank you for Your patience.

Hi, no need to apologise!
Just try the new 1.18.0 Linux binary and see if that works – I have changed added the env var above to the wrapper script so there’s a chance that it helps…