Iso values different in darktable from raw original

If this is a FAQ, please apologize. I am a newbie in DT.
I have got problems with some Nikon shots in darktable. The ISO-Compensation based on the camera model is still way too noisy.
I have that following example:

  • DT Image info says ISO is 400, accordingly the Auto denoising profile used is Nikon ISO400
  • Makernote image info shows ISO 25600, ISO2 and ISO SETTING 400, ISO Expansion Hi2.0, ISO Expansion2 Off
  • Nikon NX Studio tells ISO 6400 (+2LW)
    Camera model is Nikon D610
    If I assume correctly, the shot was taken with ISO 25600 which is the expansion of native ISO 6400 in my camera. What I do not understand is why the image information only shows ISO 400.
    Is that a bug in DT, or where is my fault?
    Thanks for all comments!

Can you share a raw file? That would make it easier to diagnose. Do you remember what settings you used on the camera?

I don’t know anything about ISO expansion on Nikon, but I suspect it doesn’t do anything good for the noise.

2 Likes

i assume the noise reduction reads the exif ISO tag, not the maker notes or anything like that. you can always manually adjust, so…

Thanks Nis
I can’t remember the settings, except that this was Auto ISO.
20160724-Japan-Reise-0033.NEF (33.7 MB)
ISO expansion is a quite common thing in modern cameras as far as I learned…

Thanks Mica
It is possible that DT takes the ISO from EXIF though I could not see this anywhere. Nikon has a proprietary image format (NEF) without sidecars, by the way.

I just looked into extended/expanded ISO, and the conclusion is that you shouldn’t use it when shooting raw. You can probably do a better job yourself when editing.

1 Like

That’s just their raw format. Canon has CR2 and CR3. Raw files never come with sidecars from the camera - they come from editing software.

I saw the same article today. It was new to me. The sad thing is, I did not even know this from my camera.
But if I understand you correctly I should only use the 100-6400 range which will hopefully not be modified be the camera firmware. NEVER Auto ISO again…

Though still the question is why DT “sees” ISO 400 in that file!?

Run the file in Exiftool and find all those ISO tags.

The problem isn’t auto ISO, but ISO expansion. Your camera will have separate settings for that.

I am still running darktable 4.4.1 on my main machine. For me darktable says ISO 25600. About NR it says interpolated ISO 8063-101597. So it will use the same NR for everything between ISO 8063 and 101597. The jump looks strange, but maybe that is how Nikon is doing it? I am a Canon guy so I don’t know Nikon.

F11 and 1/800 seconds… No wonder you needed a high ISO. F4 - F8 and 1/250 would have been much better.

digiKam says in properties that ISO (sensitivity) is unavailable:
image

But in the ExifTool tab we get this:
image

Looks like the raw has been through NX Studio:
image
That has been known to cause issues, although I have no idea if it might affect ISO metadata also.

No idea how to interpret that mess, but there you go.

About NX Studio Fix Corrupted Nikon NEF Images

Don’t use software that touches your raw files.

Thanks Peter and all! Some new findings (checked with my camera):

  1. I can only shoot up to max ISO 6400. Settings above are only possible if I step up ev, which probably was the case with the photo tested. So yes, the photo IS ISO 25600 at the end.
  2. My DT 4.6.1 must have a bug. I re-imported the photo and it still shows ISO 400 in the image information menu.
    @Nis: you are completely right. That was a mis-taken photo, and I also saw the same info in DK. From there I took the Makernote. The last remark is notable. It might have happened I used NX Studio for a test.
    Still then, @Peter: you could detect the correct ISO with the older DT version in that corrupted photo! Weird…

Select a raw file in Lighttable, go to Metadata to the right. Hit Refresh Exif. A re-import may not be enough.

And big big thanks all of you about this NX Studio issue. That software promises to put everything in its own sidecars, which I believed up to today.

Your raw file seems fine, even if it has been touched by NX Studio. The issue may be something else. Can you manually set ISO 25600 and take a new raw file? And also a sample at ISO 6400.

darktable uses Exiv2 to read metadata.

Did so.
Auto ISO up to 6400 no problem, is recognized in DT
Auto ISO up to 6400 plus manually 2ev is also recognized as ISO 6400
ISO 6400 plus manually 2ev is also ok.
ISO 25600 (shown in NX as (ISO6400+2ev) is now also correctly recognized.
Still my “damaged” sample can in no way be changed to anything else than 400 again.
Now I will put the test files above into a new directory, touch them with NX and then check with DT again…

Auto ISO 25600? Or you tried that already?