Just installed GMIC again on Linux Mint 21, tried both flatpak and DEB, but it's.... smaller?

Hello there, I’ve been using GMIC for several years now, it is one of my favorite tools.
I just installed Mint 21 on a new machine and then went through my usual motions, installing GIMP, GMIC, etc., and noticed that I can’t seem to access tons of filters through GMIC that I used to. The current version is listed as GMIC Stable 2.9.2, Oct 3rd 2022.

I’ve tried installing “all-data” from the About section, which I believe was the way one used to get all the filters.

My Windows 11 install of GMIC actually has all the filters I’m used to, as does my old Mint 18.3 Install of GMIC. I’ve actually grown very fond of a lot of the “Testing filters”: Joan Rake’s, Iain Ferguson’s, Reptorian’s, Marcel’s… and other creators whose names I would remember if I saw them…

Many normal filters just seem to be missing (Reptile, for example, in Patterns, and Metallic Look in Colors). The Color Presets (part of the gmic-clutz.gmz I think, is even smaller than usual.

Is there some way I can get the BIG GMIC back? Am I missing something?
Thank you for your help!

Here is the list of filters the 64mb All-data install had, as you can see it’s quite small, it used to be hudreds of megabytes and I think came with Testing filters and many others that are no longer part of GMIC proper.

398 filters showing in my gimp-gmic.

Gimp 2.10.32 from the ubuntu handbook ppa.

And gimp-gmic installed from Mint repositories.

Although curiously, trying to update the list of filters gives the following error.

The update could not be achieved
because of the following errors:

Could not read/decompress https://gmic.eu/update294.gmic

Hi, thanks for the reply.

I’ve also noticed this error when I try to update.
As you can see from your screenshot, there is no “Testing” section, usually located at the very bottom (not in Various), which is where filter creators would have their filters tested by users. This contained a hundred or more filters, some of them quite fantastic and had become normal parts of my process (Construction Texture was great!).

At some point I’ll get on my Windows machine and grab the list of filters to compare here, but I figure somebody would just know what the deal was.

Older versions of the Gimp Gmic plugin no longer update. Also the testing section is now incorporated into the plugin. The small plugin size from the mint repo is due to it being a ‘dynamic’ version where plugin and g’mic lib files are separate.

This is a Mint 21 (VM) with Gimp 2.10.32 from Panda Jims PPA and the gimp-gmic from the Mint repo. A mountain of files if you install it.

Get the gimp plugin for Jammy from the gmic site, It is that ‘larger’ static version. Unzip it and put it in ~/.config/GIMP/2.10/plug-ins/ With a bit of luck it will supercede the older version installed from the repo. You might/might-not need to install libfftw3

Looks like this, 584 filters


That’s the one! Thank you Rich!
Sorry to ask, but where is Panda Jim’s PPA version of GIMP located? All I’m seeing on GIMP’s site is a flatpak, the one I found online leads me to the following…

Just to be clear, should I be installing this one? I ask because the PPA description simply says: “Don’t use!”
Thank you again.

1 Like

The Panda Jim PPA

1 Like

Not quite a smooth liftoff… Got this error that GEGL was not updated.
Should I track down this newest version of GEGL, did you have to install this as well?

It looks to me that GEGL has updated to the correct Panda Jim version, but Mint comes with Synaptic package manager, so fire that up and check.

What is missing is the wildcard from the end of sudo apt install libfftw* A bit overkill but at least pulls in all the packages.

You caught me between ‘computers’ What you should look for is libgegl which Gimp 2.10.32 requires. 4.36 comes from the Panda Jim repo Version 4.34 is the stock version. You can check in Synaptic


Rich, thank you once again. Your directions are always so spot on. Everything works, all the amazing test filters are back! :slight_smile: