Just installed on new PC - images not opening correctly [solved]

I’ve been using RT for a few months now, just installed it on my newest build - AMD Ryzen 7 CPU, Nvidia 3080 GPU, 64GB Ram, Windows 10 pro

When I browse to some DNG files from my iPhone 13, and open them I get a severely washed out(?) image show up in the edit tab, and see unable to do anything with them. I thought there might be a “reset all” somewhere but I can’t find it if there is. This is a fresh install, and first time I’ve used RT on this PC.

In uploaded screenshot you can see, and see 3 images I tried to open in top panel looking the same.

Am I missing something here?

Thanks in advance…

Looks like you are using the 5.8 from Feb. 2020?

Would you mind trying a more up to date version from here?

Thanks for reply

I will try that - on another note I thought it was just on my new PC, so I tried opening the same file from my laptop & got same result, which makes me wonder if it’s an issue with raw files from the iPhone 13 pro?

The 5.8 is way older than the iphone 13. So I wouldn’t be surprised if it doesn’t support these dngs.

I installed the latest built - good now.