kyocera camera not recognized in Rapid Photo Downloader

I installed the program and plugged Camera in to USB. Linux recognizes it (and I can copy files manually) as connected but nothing shows up under “devices” in Rapid Photo Downloader. Tried disconnecting and reconnecting usb and restarting RPD before and after connecting the camera.

Rapid Photo Downloader uses a library called libgphoto2 to download from cameras. The list of Kyocera cameras supported by libgphoto2 are:

  • Kyocera 302KC
  • Kyocera C6740N
  • Kyocera DuraForce
  • Kyocera Duraforce XD
  • Kyocera Event
  • Kyocera Hydro Elite C6750
  • Kyocera Hydro Icon
  • Kyocera KC-S701
  • Kyocera KYL22
  • Kyocera Rise
  • Kyocera Torque Model E6715

Is your camera model one of these?

If not, is the camera in PTP mode, or USB mass storage?

Yes, it is the Kyocera C6725

It puts an icon on the Linux desktop when plugged in to the USB. Did not see anything in manual about a ptp mode.

To figure out what is going on do this:

  • Install the program gphoto2 using the Linux Mint software installer
  • VERY IMPORTANT: eject the camera using the Linux Mint file manager, so the icon disappears from the desktop. Do not remove the USB cable or turn off the camera.
  • Open a terminal window and run this command: gphoto2 --auto-detect

Copy and paste the output here.

1 Like

I right click selected “unmout” and the Kyocera icon disappeared from desktop.

Then ran command. No data was displayed:

james@james-desktop:~$ gphoto2 --auto-detect
Model Port

Is this a phone or an actual camera?

It is an Android phone. Kyocera VM KYO C6725 XCVR SGL

I guess you are running an old version of Android on that phone then. Presumably the phone has the capability to connect via MTP. When you attach it to the computer, are you instructing Android to connect using MTP? You should do that if at all possible.

Read this to learn more about MTP, PTP and USB mass storage: https://www.howtogeek.com/192732/android-usb-connections-explained-mtp-ptp-and-usb-mass-storage/

1 Like

I checked an there is no update to the phone beyond where it is and it only shows USB connection with no MTP or PTP options. So guess no way to make it work.

I would be most surprised if an Android 4.x phone does not allow connection via MTP.

If the only way to access the phone is via USB mass storage, then it is being mounted somewhere on your file system. Try ctrl-L while in the file browser while browsing a file on the phone to determine the precise path. Then you can manually point Rapid Photo Downloader to the correct location by using the file browser and turning off device detection.

Thanks, I used the control-L and got the link but I can’t see to find where exactly in RPD interface I can enter the link. I don’t see a place to enter an url.

Unfortunately Rapid Photo Downloader does not have a way to enter a URL using the user interface. You need to navigate the tree of directories on the left-hand side under the “This Computer” section, and click on the folder you want to download from using the left mouse button. Do not click too early in the directory tree or else it will scan every single file under that sub-tree looking for photos and videos. Let us know if you have any questions about that.

In the Linux file browsers I see all my devices listed including the camera which is listed as “Kyocera USB modem” but in the RPD interface I don’t see any such item, there are some drives under “Devices” but no Kyocera there.

Since the phone runs Android 4.3, it SHOULD support MTP. There is also a possibility (but not guaranteed) it may also support USB Mass Storage for certain use cases. (This is only seen in much older Android devices, usually ones with user-addable SD cards).

Many devices have “flaky” MTP support that doesn’t play nice with the built-in MTP implementations on many Linux distros. I’ve found that I’ve often had to resort to Android File Transfer ( https://whoozle.github.io/android-file-transfer-linux/ ) instead with many devices.

Your device will not show up in the “Devices” section of Rapid Photo Downloader because it is not set to use MTP. That’s the same reason why gPhoto2 is unable to detect the device.

Because your phone is not set to use MTP, if you want to use Rapid Photo Downloader, you must manually specify where you want to download files from using the “This Computer” setting. As I said earlier, you can get the correct directory from your regular file browser and use that to navigate to the correct location in “This Computer” in Rapid Photo Downloader.

See the Computer tab on the left and it has tons of directores listed but I do not see within that how to point it to url I got va the ctrl-L. What do I click on to manually specify the url/location?

Copy and paste here the URL you got from the file manager using Ctrl-L, and I will assist.

The ctrl-l link is mtp://%5Busb%3A003,007%5D/PHONE/DCIM/100KYCRA

Thanks,
James

The device is in MTP mode. Please confirm the toggle switch for “Devices” is turned on — see the documentation here:

https://damonlynch.net/rapid/documentation/#sources

If it is turned on, and the device is not showing, then there is nothing that can be done because it means libgphoto2 is for some reason not detecting the device.