Latest RTW64NightlyBuilds not working for me

I always update to the latest André builds, but unfortunately don’t keep previous installers around. I had an older wavelet build still working, but lost that too when I tried a full uninstall of everything just now.

So these are the two latest from the keybase site that I tried:

When I try to launch them, nothing happens. Had to install ‘’ to have any working install.

Ping @gaaned92 when he has a free moment :slight_smile:


An automatic Travis CI build system was setup by @Carmelo_DrRaw for Rawtherapee. The provided builds have the same characteristics as those I provided, except there is no installer.
You can get them here: Release Automated Builds · Beep6581/RawTherapee · GitHub

see also Download RawTherapee development builds

As, providing the same builds would be pointless, I decided to generate mor optimised builds. Those builds can only be run on
skylake processors and above.

So I suppose your processor is not compatible. Could you provide your CPU characteristics?

If you see a drawback or an issue in this situation, don’t hesitate to share.
I should have documented this modification. Sorry for inconvenience.

1 Like

Yeah, running an old dog here, 1st Gen i7, 870@2.93GHz, 4 cores

No chance to run skylake builds :hot_face:


Can you provide a less specific build, which will work on most (though still not all win64 systems) with
-msse4 for example. Not targeting a special cpu, but a feature?

Try this command to get what’s enabled on your machine and restrict the build to the features which you think of being available.

gcc -march=native -Q --help=target

Edit: Let me eloborate a bit more on this (for windows x64 builds):

There are only a few x64 cpus which do not support SSE4 and these cpus are quite old.
Means, providing a standard-build and a SSE4 build could be usefull.

Especially to me! :smiley:
As much as I’d love to build a less ancient tower, I just moved and it can’t happen any time soon.

march=nehalem is the first architecture to provide sse4 (nov 2008)
If you agree I will build for this architecture.

1 Like

Why use an -march instead of a feature (-msse4) ?

@todd For max speed, build rt yourself using -march=native

@heckflosse Is there a play by play for this? I’ve never done it. (I’ve never built rt in any form or fashion)

Thanks I’ll give it a try.

Where will this go in the process? I’m at the installing tools and libraries stages right now…

-march is a compiler flag.

Can anyone explain in simple terms what I am supposed to do here? It’s not making sense to me.

Are these files supposed to be present/downloaded? They don’t seem to be there based on a couple sample searches I did in that folder. How do I download them? There look to be many thousands of files… Certainly I’m not expected to download each, one at at a time, am I?

If they do have to be downloaded, then it seems to say they have to then be downgraded. Pacman -U? And it says this has to be done for each of these many hundreds of files? I could never keep track of that even if I had days to try it…

Thanks, and how do I use it? Guessing I’ll get to that, if I ever get there… Not looking good for me at the moment… :slight_smile:

I am having a severe migraine at the moment and my father is in ICU, so I am not thinking clearly. I think it ought to be in the makefile using the -DCMAKE_C_FLAGS and / or -DCMAKE_CXX_FLAGS.

Please hang in there and feel better soon!

1 Like

I’ve uploaded the downgrade packages to filebin.

Run mingw64.exe and type
pacman -U <path>/mingw-w64-x86_64-lensfun-0.3.2-4-any.pkg.tar.xz
Hit Enter

pacman -U <path>/mingw-w64-x86_64-libjpeg-turbo-1.5.3-1-any.pkg.tar.xz
Hit Enter

1 Like