LBB SSD problem

Hi all

I’m currently trying to get LBB working on an Rpi4 with a portable SSD drive.
I have the same issue with both the Samsung T5 and G-Technology G-Drive mobile ssd, the drives mount fine but when I plug in my SD card reader the Rpi4 crashes.

At first I thought it was a power draw problem but I wiped the OS sd card and installed raspbian desktop and was able to use both just fine that way. So I’m looking for anyone who can offer any ideas on how to get this working?

Do you use Raspberry Pi’s USB 3 ports? If you do, try using USB 2 and see if the problem persists.

Just tried that same problem, about 5 seconds after inserting the card reader, the Pi crashes and I have to reboot.

I just tried with the SSD connected via usb3 and the Card reader in usb2 and it seems to be working happily although the transfer is much slower obviously. Do you think this is a hardware limititation or something you might be able to fix?

Yep, I have this problem too. My Raspberry Pi 4 seemed to work fine until around EEPROM was introduced. So I’m inclined to think that it’s a solvable problem. But it’s nothing that I can fix.

I recently acquired Raspberry Pi 4 8GB model in hope that this issue has been addressed in the new board revision. I haven’t had time to test it, though.

1 Like

By the way, you could use a USB 3 hub as a workaround. I tried this one from Anker (, and it worked like a charm. It’s not ideal, but may be better than using the slow USB 2 port.

Reporting no crashes for me. I’m using an X872 v1.1 as my onboard NVME storage (500GB) plugged into USB3 port.

When inserting a 64GB XQD card, it automatically backs up, although at only 20MBs (a current problem we are all aware of)

Although the pi4 goes to sleep after only about 20 seconds of standby rather than 1 minute!

Great software. Bought the book on google as a way to help show my appreciation. Keep up the good work!

1 Like

Thank you very much for your report and for buying the book!