Literally Black and White images

I’m capturing with a Canon 550D, and i’m literally seeing black and white images (no grey), looking close up i’m seeing a white star with more dispersed white/black pixels as it fades. I see this on the previews, in every colour channel, and once stacked in affinity the image is a simple sea of black with white stars.
I can process the same images in sequator, affinity, deep sky stacker and they all create grey scale images, with hints of colour. But none of them are black and white.
I’m using both the September and the 0.9.12 version.

Hi, hard to guess from what you describe…
Could you at least share a screenshot of Siril interface with your image loaded or better, share an image so that we can have a look?

The first image is what seems to be loaded when the CR2’s are converted.

Which looks OK, there are grey scales etc. I’ve tried every kind of raw debayer interpolations and they all look broadly the same, I assume that there are some pixel level differences somewhere but these are not causing the issue.

I can’t seem to recreate it right now (I have rebooted), but instead of greyscales as the above image, all I would get is 100% black or 100% white. Will try again to recreate tonight.

From what I see, my best guess is:

  • the image is not debayered
  • you are probably previewing in linear mode

So when you open a converted fits:

  • check debayer in the file dialog
  • use Autostretch as preview mode

If my guess is wrong, then pls share a file. a CR2 so that we can look into it.



1 Like

All looks ok now, I seem to recall that I had a good stack, and then just a series of bad ones, rebooted and now good again. Not saying it’s a bug, but I must have tried a dozen times last night all failed. I’ll come back it I see it again. I didn’t debayer the lights, but I did debayer in pre-processing.