lua scripts doesn't work with darktable 4.8.0 for windows

Hello, I installed new version of darktable for windows, external editors scripts doesn’t work, same thing for export to gimp.

Run with -d lua, and attach the log.
C:\Users\your-user\AppData\Local\Microsoft\Windows\INetCache\darktable\darktable.log (some directories on the path may be hidden)

Thanks for reply.
error message: error launching gimp

Is that the complete log?

Do you have the executable manager (from the tools category) running? Does it show the gimp? Interestingly, I only have git available (the drop-down has no more entries), but then I never use Lua:

This box appears, but doesn’t work.

I removed all the files from DarkTable and uninstalled it. I’ll try to reinstall it and see if it works.

It still doesn’t work

Reinstalling will only help if the software is damaged. Removing darktable does not delete its configuration and data files.

Maybe @wpferguson can help?

If you could attach a log file that you generated with -d lua, it could prove useful.

Were you running a previous version of darktable with the scripts working?

If so, did you upgrade from the previous version or did you install clean.

Did you configure the name and path for external editors in the lua preferences?

What version of windows are you running?

When you say executable manager doesn’t work, what does that mean? Was it just an empty box?

The previous version worked fine, I was able to export JPEG files to GIMP, using the Export module. The same goes for retouching with external editors.
On the new version, I reinstalled the lua scripts, on the external editors page I put back the links to the executables of the external software. Nothing works. When I try to launch an external software I get an error message launching gimp

windows 11

For me, on Linux, the executable manager’s drop-down only contains git (see screenshot in one of my previous posts).

Edit: I’ve done a restart, and now there are more options, including gimp:

here’s what I have under windows 11

Have you tried starting the executable manager, to define where gimp is installed?


Windows are different in Win 11



Isn’t this a GIMP issue, discussed elsewhere?

No, that’s when you try to use darktable as a raw converter from Gimp.

If you copy the whole path from Actuelle, and try to run it , does Gimp start? Alternatively, if you follow the directory structure in Explorer, is it correct?

That’s what I did and it still doesn’t work. I checked all the paths and they are correct.