Luminance HDR 2.5.0 compilation issue

(Brian Innes) #1

It looks like Luminance HDR 2.5.0 has just been released. I’m going to try and compile it on my linux mint 18.1 machine. Wish me luck!

Edit. Looks like I’m going to run into major issues, as Linux Mint 18 (based on Ubuntu 16.04) doesn’t have the required library of qtwebengine5-dev

(Brian Innes) #2

Hmm. So far so good.

I installed QT 5.6.0 open source package which contains all the precompiled binaries from the QT website

I then pointed Cmake to this directory with the command

cmake -DCMAKE_PREFIX_PATH=~/Qt5.6.0/5.6/gcc_64/lib/cmake/ ./

and then installed any missing development libraries which cropped up via synaptic.

However the build of Luminance HDR fails at

[ 46%] Linking CXX executable luminance-hdr-cli

Seeing as I’m not a programmer in any form, I’m loathed to spend much more time on this. A shame that there isn’t an appimage available for Luminance HDR.

Perhaps it could be due to the fact that I’m running Linux Mint 18, which is based on Ubuntu 16.04? Perhaps it is “too old” for easy compilation of Luminance HDR? I’m not keen on installing another distro just for one application though…

It’ll be interesting to see if any one has any luck with this software…

(Morgan Hardwood) #3

@Brian_Innes paste the full compilation log, maybe we can help.

(Brian Innes) #4

@Morgan_Hardwood, I’ve actually managed a compilation of Luminance HDR 2.5.0 on Manjaro Linux 17.01 :slight_smile: Pretty painless as this distro seems to have all the required up to date dependencies compared to Linux Mint 18 (which was based on ubuntu 16.04).

Whether Manjaro will be a long term distro for me is another matter as I seem to used to the ubuntu / debian way of doing things, however the rolling “release” of manjaro appeals to me (at least until I break the install…)

(Franco Comida) #5

Some Linux distros do not provide QtWebEngine and so compilation fails on those systems. I just uploaded a patch for switching from QtWebEngine to QtWebKit. It can be found on sourceforge: luminance-hdr-2.5.0-qtwebkit.patch

(Mike Bing) #6

Mine compiled fine on ArchLinux. Haven’t tried on PCLinuxOS just yet but will do tonight and post results.

(Brian Innes) #7

Ha ha! I just managed to break my Manjaro install messing about with the video card drivers. So back I go into Linux Mint 18 (like a pair of comfortable slippers).

@Morgan_Hardwood I’ll look at the compilation in more detail once I get Mint up and running again, and I’ll put up the full compilation log. I’m sure I won’t be the only person running mint 18, so if it helps anyone else who is trying to install Luminance HDR 2.5.0 then I’m more than happy post the compile log…

@fcomida I’ll have a go at applying that patch, and see if that helps. While I had Luminance HDR 2.5.0 running in manjaro, it looked like a lot of work had been done since 2.4.0, so thanks for the time spent developing this great software.

(Franco Comida) #8

In the meantime a nasty bug has been fixed. Pull latest changes from git, 2.5.1 will be out soon.

(Brian Innes) #9

@Morgan_Hardwood, here is my build log while compiling on linux mint 18.1, which is based on ubuntu 16.04, which ships with Qt 5.5.1 as standard.

The main failure seems the be here:

[ 61%] Building CXX object src/BatchTM/CMakeFiles/batchtm.dir/BatchTMDialog.cpp.o
/home/brian/Downloads/Graphics/LuminanceHDR/luminance-hdr-2.5.0/src/MainGui/main.cpp: In function ‘int main(int, char**)’:
/home/brian/Downloads/Graphics/LuminanceHDR/luminance-hdr-2.5.0/src/MainGui/main.cpp:94:33: error: ‘AA_EnableHighDpiScaling’ is not a member of ‘Qt’

Full build log below.

 brian@Escher ~/Downloads/Graphics/LuminanceHDR/luminancehdr-build $ make -j4
[  1%] Built target hdrhtml-cli
[  2%] Built target pfsadditions
[ 11%] Built target pfstmo
[ 23%] Built target pfs
[ 25%] Built target hdrcreation
[ 26%] Built target main_cli
[ 27%] Built target osintegration
[ 29%] Built target core
[ 33%] Built target common
[ 34%] Built target exif
[ 34%] Built target fileformat
[ 35%] Built target align
[ 37%] Built target hdrwizard-cli
[ 38%] Built target hdrhtml
[ 46%] Built target viewers
[ 46%] Building CXX object src/MainGui/CMakeFiles/main_gui.dir/main.cpp.o
[ 48%] Built target previewpanel
[ 49%] Built target qtwaitingspinner
[ 55%] Built target mainwindow
[ 56%] Generating ui_BatchTMDialog.h
[ 57%] Built target batchhdr
[ 57%] Generating moc_BatchTMDialog.cpp
[ 57%] Generating ui_EditingTools.h
[ 58%] Generating ui_HelpSideBar.h
[ 58%] Generating moc_HdrWizard.cpp
[ 58%] Generating moc_helpbrowser.cpp
[ 60%] Generating moc_HelpSideBar.cpp
[ 60%] Generating moc_EditingTools.cpp
[ 60%] Generating moc_sctextbrowser.cpp
[ 60%] Generating ui_HelpBrowser.h
[ 61%] Generating moc_PreviewWidget.cpp
Scanning dependencies of target helpbrowser
[ 61%] Generating ui_HdrWizard.h
[ 61%] Generating moc_BatchTMJob.cpp
Scanning dependencies of target hdrwizard
[ 61%] Building CXX object src/HelpBrowser/CMakeFiles/helpbrowser.dir/helpbrowser.cpp.o
[ 61%] Building CXX object src/HdrWizard/CMakeFiles/hdrwizard.dir/AutoAntighosting.cpp.o
Scanning dependencies of target batchtm
[ 61%] Building CXX object src/BatchTM/CMakeFiles/batchtm.dir/BatchTMDialog.cpp.o
/home/brian/Downloads/Graphics/LuminanceHDR/luminance-hdr-2.5.0/src/MainGui/main.cpp: In function ‘int main(int, char**)’:
/home/brian/Downloads/Graphics/LuminanceHDR/luminance-hdr-2.5.0/src/MainGui/main.cpp:94:33: error: ‘AA_EnableHighDpiScaling’ is not a member of ‘Qt’
src/MainGui/CMakeFiles/main_gui.dir/build.make:62: recipe for target 'src/MainGui/CMakeFiles/main_gui.dir/main.cpp.o' failed
make[2]: *** [src/MainGui/CMakeFiles/main_gui.dir/main.cpp.o] Error 1
CMakeFiles/Makefile2:978: recipe for target 'src/MainGui/CMakeFiles/main_gui.dir/all' failed
make[1]: *** [src/MainGui/CMakeFiles/main_gui.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 61%] Building CXX object src/BatchTM/CMakeFiles/batchtm.dir/BatchTMJob.cpp.o
/home/brian/Downloads/Graphics/LuminanceHDR/luminance-hdr-2.5.0/src/HdrWizard/AutoAntighosting.cpp: In function ‘<built-in>’:
/home/brian/Downloads/Graphics/LuminanceHDR/luminance-hdr-2.5.0/src/HdrWizard/AutoAntighosting.cpp:111:5: warning: ‘p’ may be used uninitialized in this function [-Wmaybe-uninitialized]
     for ( int j = 0; j < height; j++ ) {
/home/brian/Downloads/Graphics/LuminanceHDR/luminance-hdr-2.5.0/src/HdrWizard/AutoAntighosting.cpp:77:16: note: ‘p’ was declared here
     fftwf_plan p = NULL; // Let's see if this blocks compiler warnings
[ 62%] Building CXX object src/BatchTM/CMakeFiles/batchtm.dir/moc_BatchTMDialog.cpp.o
[ 63%] Building CXX object src/HdrWizard/CMakeFiles/hdrwizard.dir/HdrWizard.cpp.o
[ 63%] Building CXX object src/HelpBrowser/CMakeFiles/helpbrowser.dir/HelpSideBar.cpp.o
[ 63%] Building CXX object src/BatchTM/CMakeFiles/batchtm.dir/moc_BatchTMJob.cpp.o
[ 63%] Building CXX object src/HdrWizard/CMakeFiles/hdrwizard.dir/EditingTools.cpp.o
[ 63%] Linking CXX static library libbatchtm.a
[ 63%] Built target batchtm
[ 63%] Building CXX object src/HdrWizard/CMakeFiles/hdrwizard.dir/PreviewWidget.cpp.o
[ 63%] Building CXX object src/HelpBrowser/CMakeFiles/helpbrowser.dir/LuminancePaths.cpp.o
[ 64%] Building CXX object src/HelpBrowser/CMakeFiles/helpbrowser.dir/schelptreemodel.cpp.o
[ 65%] Building CXX object src/HdrWizard/CMakeFiles/hdrwizard.dir/moc_HdrWizard.cpp.o
[ 65%] Building CXX object src/HdrWizard/CMakeFiles/hdrwizard.dir/moc_EditingTools.cpp.o
[ 65%] Building CXX object src/HdrWizard/CMakeFiles/hdrwizard.dir/moc_PreviewWidget.cpp.o
[ 65%] Building CXX object src/HelpBrowser/CMakeFiles/helpbrowser.dir/sctextbrowser.cpp.o
[ 65%] Building CXX object src/HelpBrowser/CMakeFiles/helpbrowser.dir/treeitem.cpp.o
[ 65%] Linking CXX static library libhdrwizard.a
[ 65%] Built target hdrwizard
[ 65%] Building CXX object src/HelpBrowser/CMakeFiles/helpbrowser.dir/treemodel.cpp.o
[ 66%] Building CXX object src/HelpBrowser/CMakeFiles/helpbrowser.dir/moc_helpbrowser.cpp.o
[ 66%] Building CXX object src/HelpBrowser/CMakeFiles/helpbrowser.dir/moc_HelpSideBar.cpp.o
[ 66%] Building CXX object src/HelpBrowser/CMakeFiles/helpbrowser.dir/moc_sctextbrowser.cpp.o
[ 67%] Linking CXX static library libhelpbrowser.a
[ 67%] Built target helpbrowser
Makefile:127: recipe for target 'all' failed
make: *** [all] Error 2
indent preformatted text by 4 spaces

(Pat David) #10

Hello @fcomida! So great to see you here, and thank you very much for all of your work! :grinning:

(Franco Comida) #11

I disabled those functions on Linux, there are issues with HiDPI on Linux, see

I do not have access to a 4k monitor, linux users can try setting QT_AUTO_SCALE_FACTOR env variable for now.

When a general fix is found I’ll enable those function again on Linux if QT5 >= 5.6
Pull latest commits from git, it should compile.

(Franco Comida) #12

Hello @patdavid, thank you. All the discussions here are helping Luminance HDR getting even better :smiley:

(Brian Innes) #13

I tried installing Qt 5.7.0 on my linux mint 18 box.

A bit further forward, but still not compiling, even after applying the qtwebkit patch… it fails at 95%:

[ 95%] Linking CXX executable luminance-hdr
/home/brian/Qt5.7.0/5.7/gcc_64/lib/ undefined reference to QNetworkRequest::QNetworkRequest(QUrl const&)@Qt_5' /home/brian/Qt5.7.0/5.7/gcc_64/lib/ undefined reference toQNetworkReply::url() const@Qt_5’

Has anyone been able to compile on a ubuntu 16.04 / linux mint 18 machine? I’m a bit out of my depth here? I think I may end up having to stick with the old 2.4.0 release of Luminance-hdr until a more up to date ubuntu / debian package gets released, or even an appimage?

(Brian Innes) #14

Thinking out loud with regards to my compilation issues, perhaps the fact that I’m running Mint 18, which is based on Ubuntu 16.04 may be what is causing me problems.

Seeing as there is nothing on the telly box tonight, I may as well reinstall manjaro! At least I was able to compile Luminance HDR easily on Manjaro, I’ll just not play with the video card drivers this time…

(Brian Innes) #15

A quick install of Manjaro, and a compile of Luminance HDR from the git tree, and I’m now running the latest version of Luminance HDR! I’m testing it out with a sample hdr image from the pfstools website,