Manual alignement of RGB frames

Hello,

I am trying to RGB compose 3 fits, but the images are not alligned.
I tried the alignement in the RGB composing, but it did not work well.
I tried putting the 3 images in a sequence and align this way, but this also failed.
They are what looks like manual alignment numbers in the RGB composing box, BUT it is not possible to edit them :frowning:

Would it be possible to enable these control for manual editing so that one could manually adjust the frames?
Thanks,
Cyrille

Hello.
Why alignment in sequence fails? It shouldn’t: I do this way all the time.

Hello,

I would love to know why it’s failing! but I am too new to the whole thing to have a clue.
I can provide the 3*64MB fits to anyone who needs them for testing/debugging/finding what I am doing wrong…

Thanks,
Cyrille

You can share your files yes. But everything is written in the console.

Hello,

The problem is that to siril, it looks like it worked, no errors are reported, it’s just that the end restul is not aligned…

However, I think that I might know the cause of the error. I think that my 3 images were not histogram stretched correctly. BUT that lead me to another issue:-(

I was able to stretch the S and OII layers, but when I tried doing the same with the Ha layer, it failed in this following way:

This is my “base” Ha layer using linear visualisation:
image

This is the same layer using auto-stretch visualisation:
image

But when I open the histogram tool and click on the “auto” button, I get a white image:

It does not mater what I do when I try to manually adjust the histogram, I am unable to get to anything remotely as nice as the one from the “visualisation/auto stretch” mode. Is there a way to get the computer parameters from there to apply them to the histogram tool?

Thanks,
Cyrille

Here is the link to the HA file
https://drive.google.com/file/d/1EtPvq5SL0e9W-mJ6IjzMq1Mzyx7onp_g/view?usp=sharing

This works as expected, to view the stretched image you need to move the visualisation cursors, similarly to that Why are exported images so dark? in the FAQ.

They are indeed read-only, displaying registration results, I don’t remember why we didn’t handle user input from there… Anyway, this tool is becoming deprecated in 1.2, I’m not sure we’ll update it.

Yes, I understood this…

However, when I use the histogram tool and click on the “auto” button (the cog one), for my S or OII images, I end up with a setting that looks very similar to when I select the “auto stretch” in the visualisation drop down.

But for the Ha image, the cog button yeilds a white image and regardless of how I try to manually tweak the histograms sliders, I am not succeeding in getting anything that looks remotely nice.
Is there a way (console?) to get the values that the “auto stretch” selection uses so that I can copy/paste them in the histogram window?

Thanks,
Cyrille

I had no problem to apply autostretch from the histogram tool to your image, it’s not the histogram sliders that must be set to 0 and max but the image visualization sliders below the image display.