Menu fonts too small

I am a new user to GIMP but I find the GIMP menu fonts way too small for me to use comfortably. I am aware that there is a way using gtkrc to correct this issue however in-spite of numerous on-line tutorials and attempts to do so, I have not been successful in accomplishing it. Also, I do not know how to use Terminal commands. I would greatly appreciate it if some one could provide complete step-by-step instructions for enlarging the menu fonts. I like the program very much and if I could correct the font problem I will make a donation to GIMP. I am using Mac Os Catalina.
Thank you.

1. Make sure you are editing the correct file. On Windows, I see multiple gtkrcs.

image

2. You don’t have to use Terminal. The key is to use a text editor that doesn’t mangle the file. A text file has invisible features such as encoding and newline marks that a text editor can overlook and override. The key is to backup the files before you edit in case something goes wrong. I think it should be fairly straightforward, since macOS is UNIX-like. Drag-and-drop or open the file and make the appropriate GTK CSS edits.

Thank you for your reply Alan, unfortunately I cannot find anything in Mac Os Catalina that looks like what you have described.

Unfortunately, I am more than a decade removed from Macs, so I can’t help you with the latest OSes and GIMP installations, but web search engines and GIMP help forums (and this one) are your friends. Should not be too hard to find a solution. :wink: There are also some macOS users around if you could research their names and try to @ them.

Thanks again for your help Alan, I’ll get it figured out eventually.

Hi David,
So glad I’m not the only one with problem.

I’m not on a Mac this year, but I’ll tell you how I fixed the problem and maybe there is a way to do it on a Mac too.

First I went to my Windows Settings and went to the Display Settings and under Scale and Layout I changed it from 100% to 125% and that makes everything on my computer a bit bigger and easier to see. There’s only a couple of apps that don’t work well with my settings (I can’t see a full menu or something like that) so then I will go and change it back while I’m working with that app and then go change it back to 125% when I’m done.

The other thing I do is in Gimp itself.
Click on Edit > Preferences
On the left Menu Click on Interface then on Icon Theme. I find by choosing the Color Icon Theme the Icons are bigger and easier to see.

I wish the little cursor that shows when I’m trying to widen the Layers column on the right was not so teeny. I’m sure there are a lot of older ones (me included) who use GIMP. And it would be especially difficult for anyone of any age with visual problems.

I hope you’re able to use some of this to make GIMP easier to use for you. :smile:

Thank you for your response, unfortunately that does not work for enlarging the fonts. Regards.

In MacOS go to Settings → Display and choose Scaled for resolutions. There you can either choose bigger fonts or a lower resolution than the default one for your screen. I, personally, use HiDPI for MacOS and Retina Display Manager app for quickly switching resolutions.

Cheers,

Thank you for your reply. What you describe is changing the font size in MacOS, what I am attempting to do is to change the font size in the GIMP app.