Missing FastNoise Node

One thing I miss often in Natron is some kind of FastNoise / CloudNoise generator node as we had in BMD Fusion.

Its often used to animate stuff like flickering lamps, slightly changing the color of a texture, simply displace textures to look like curtain/cloth, crating fog and so on…

I am aware of the Shadertoy node, but this one takes a lot of resources and its quite hard to figure out a similar setting and its not easy to change speed, scale and detail…

Which tricks are you using?

fastnoise

Anything wrong with SeNoise?

And if you want to animate it, set an expression on Z0 (eg “frame” if you want a different pattern at each frame)

Amazing!

Thank you for the hint, did not know the SeNoise node, its exactly what I was looking for,
with an expression set to: frame*0.01 I got the desired effect:

seNoise

1 Like

But now I need to find out why it does not render as displayed in the viewer node,
using “Divide” in Merge renders only my ocean texture… the other operations like “reflect” do render as displayed in viewer.

I never used divide, so there may be a bug. Can you post an issue on GitHub with a sample project?

Although my guess is that you probably set SeNoise to output RGBA, and dividing by it just changes the alpha of your output? Uncheck the A channel in Merge to get the desired effect (you don’t want to divide alpha by the noise, right?)
Alpha is premultiplied by default in Natron, and when writing to RGB formats or unpremultiplied RGBA (eg PNG), Natron unpremultiplies first, thus canceling the effect you see in the viewer.

A good practice to display if there are unwanted transparencies: check the “checkerboard” button in the viewer.

I have the slight feeling that there is an overall error in the Merge Node, maybe I am misunderstanding its usage, but when I got it right, then there are following issues:

The Merge node works as expected.
Just add an alpha channel to your Solid nodes (output components = RGBA or check “A” channels in the Merge node).
Also be careful that your SeNoise creates the same noise in the A channel, which is definitely not what you want here.
One solution: add a solid node as its source, set the output components of the Solid to RGBA, and uncheck the A checkbox in SeNoise to get a solid noise (check the alpha values in the viewer). There are many other ways to get the same behavior.

Thanks for your clear explanation, now I start to understand the behavior of the Merge and it solves many headaches I had recently… :+1:

I start to have really fun with the “SeNoise” node:

Nice!
You actually don’t need to set an expresson on Z: I forgot about the “Z slope” parameter. That way, you can more easily control the speed.
Also, you may want to reduce the nmber of octaves for a smoother motion.

1 Like

A yes,
I was so concerned about the Alpha stuff that I forgot to play with the other sliders in the SeNoise… :joy: