Missing lens correction darktable 3.0.0

I’ve just built and installed the 3.0.0 release version (I’m on Manjaro). While other software (Gimp, Digikam) finds and uses the Lensfun libraries, my lens correction module seems to have gone missing. Is there a “–with-lensfun” or similar I should have used in the build process? Both Lensfun as well as Darktable are in the correct /usr paths.

I must be doing something wrong here, but what?

EDIT: just ran from konsole and found:

[iop_load_module] failed to open operation `lens’: liblensfun.so.2: cannot open shared object file: No such file or directory

Symlinking liblensfun.so.0.3.2 to liblensfun.so.2 solved it

1 Like

I have the same problem (after a lensfun update). Could you describe how did you make the change? (I am on Manjaro as well).

Similar issue on ArchLinux but in my case it’s complaining about missing liblensfun.so.1, after upgrading to lensfun 0.3.95 and latest darktable master.

If I create liblensfun.so.1 as a symlink to liblensfun.so.0.3.95 darktable coredumps.

Edit: For now I downgraded lensfun to 0.3.2, which seems to sort the issue. It looks like 0.3.95 is listed as an Alpha version so I don’t know why the packager released this.

See also Lensfun API: 0.3.95 vs master

Apologies for the multiple edits on the previous post. I’ve been posting as I’ve been investigating and I should have waited until I finished.

Darktable does work with the newer version of lensfun but it must be compiled after it’s installed. So if you’re using darktable master, rebuild it after installing lensfun 0.3.95 (which is how I finally resolved the issue).

If you’re using the Manjaro/ArchLinux packaged version, downgrade lensfun to 0.3.2 for now and raise an issue against the darktable package with the error. The package maintainer will have to update it to work with the new version.

Another edit: The current packaged ArchLinux version does seem to already have the fix.

1 Like

I have uninstalled lensfun 0.3.95 and strangely, darktable has gone with it! So installing lensfun 0.3.2 did not help (without darktable present). Re-installing darktable brought back a darktable missing the “lens correction” module as before the incident.
I will be waiting for a new version of darktable as I am reluctant to mix packages from another source (even if that is from Arch).
EDIT: Gimp has also gone!!!

I wasn’t suggesting you uninstall lensfun, just downgrade to 0.3.2. Previous versions of the packages should be in /var/cache/pacman/pkg. Just install the previous version with ‘pacman -U’.

Please note that while darktable does support 0.3.95 I’ve seen notes on a few darktable issues that suggest support is experimental and there may be problems. I’m still not entirely convinced the new lensfun version should have been released by the maintainers, given it’s still an Alpha release.

As such I’ve now gone back to 0.3.2 and will wait for a stable release of lensfun.

1 Like

Thank you, Chris.
Now I have installed lensfun 0.3.2-9 and 0.3.2-7 packages as you described (the first did not work, then I installed the other).
Still no lens correction module.
Do I need to do something within darktable? Do yo think a reinstallation is needed?

Unfortunately I don’t use Manjaro so I don’t know where you’re sourcing the darktable package from (I think it uses different repos to Arch). It all depends what version darktable has been compiled to work with.

It’s possible that since you raised this issue, the maintainer has updated darktable to work with the latest version? What error do you get if you run darktable from the command line?

1 Like

There is a strange message! :slight_smile: [bulent@bxxxx home]$ darktable

(darktable:29318): Gtk-WARNING **: 15:14:54.227: Theme file for xcursor-breeze has no directories
[iop_load_module] failed to open operation `lens’: liblensfun.so.2: cannot open shared object file: No such file or directory

(darktable:29318): Gtk-WARNING **: 15:14:55.097: Theme file for xcursor-breeze has no directories

I don’t understand this: I remove (uninstall) the installed lensfun package THEN, darktable and GIMP are also uninstalled. Perhaps something else also broken : (

what’s the output of the following command: “ls -l /usr/lib/liblensfun*”

ls: cannot access ‘/usr/lib/liblensfun*’: No such file or directory

I don’t understand why you’re uninstalling lensfun. You can run pacman -U to downgrade a package without first uninstalling the previous version. I suspect gimp and darktable are gone because they depend on lensfun being present.

1 Like

Probably because you uninstalled lensfun! Reinstall v0.3.2 then install darktable again.

1 Like

Oh yes, indeed. I wasn’t aware that GIMP and darktable were dependent on lensfun. I thought it was an optional DB. Will re-install now (the earlier version). At least, the GIMP will be fine : ) … I will wait for the next darktable package from Manjaro repositories. Many thanks for your guidance…

1 Like

darktable is packaged with the latest 0.3.95 version and it replaces the v0.3.2.

So if you upgrade everything you don’t get the error any more?

lens correction module is back, as you guessed!

Yay!

1 Like