Missing libraries?

Let me try this again. I downloaded the Windows x64 version of darktable to my laptop (Dell Latitude 3500, Intel UHD Graphics). It seems like there may possibly be some .lib files that are missing in my Windows build and therefore some functionality–particularly in the lighttable – is missing (i.e., can’t select a particular photo, can’t use multi-select, can’t apply “styles” up front to a variety of selectable slides, etc.) This is a powerful piece of software and would love to have full functionality on my Windows machine.
Anyone have any suggestions for me?

If opencl works in this setup and its turned on try turning it off and see how you make out…

Todd, thanks for this. Now all I’ve got to do is figure out OpenCL :smile:
Admittedly, while I’m better at computers than most, I am out of my league here.

Reading the documentation would help, there’s a section on OpenCL. Disabling it is done in settings, using a graphical toggle.
But selecting photos and applying styles… I don’t think that has much to do with OpenCL. I’m on Linux, though.

Look under “global preferences” (cog wheel icon) and then "cpu / gpu / memory ". Deactivate “activate OpneCL support”.

Perhaps update your video driver if there is one??

What makes you think this has something to do with missing libraries?
I can’t figure out what some of the problems you list mean, e.g.:

  • can’t select a particular photo - what does that mean? When you double-click a photo, the darkroom is not activated? Or you cannot make a selection, like you would in a file manager, to perform operations like copy/paste history stack, remove/delete photo etc?
  • can’t apply “styles” up front to a variety of selectable slides - what do you mean by selectable slides? And by apply[ing] “styles” up front?

Could you please perhaps post some screenshots? You can paste them directly into the message editor.

So, if I double click a slide in lighttable, sure enough, it takes that slide to darkroom. However, it is my understanding that within lighttable, a single click highlights a slide and makes copy/paste history stack possible. instead, as soon as I remove the mouse cursor (it’s active when I hover the mouse), the slide is then inactive and items like “copy” are grayed out.
I’m not sure how to take a screenshot of a slide NOT being selected…but hope my verbiage clears this up.

I think ultimately, this may be my problem: the Intel graphics. No, no updates. I may have to move this operation to my big desktop down in the basement which is far more sophisticated a machine than my laptop.

1 Like

I’m sorry, but I don’t get this.

  • What gave you the idea that libraries are missing? darktable ships with everything needed in the package; if some system library were missing, darktable would probably simply refuse to start, or crash – and it wouldn’t be the only software affected.
  • OpenCL is only used to accelerate image processing computations, it’s not used when you select items and move around on the lighttable (it may be used to create thumbnails etc., but should not be involved when you move around). Plus, as far as I know, the Intel driver is blacklisted (not used), as the GPU built into Intel CPUs does not give enough performance advantage.

I think you’re investigating in the wrong direction. You could check whether OpenCL is involved by disabling it in settings, see:

It was a guess to suggest this (OPENCL) but there have been many reports over the last few years of some weird issues in the GUI or results of modules and it was in many cases resolved by dropping openCL…and its an easy thing to check just in case…

There is a comprehensive system for copying and pasting the ‘history’ from one image to another and that is to be found on the right hand side menu of the lighttable. Select your image and while it is selected open up the history-stack the rest should be blindingly obvious.
If you are new to darktable you really need to invest some time in either reading the manual or looking at some basic videos (there are many), otherwise you will be wasting a lot of your time and that of others.
I run dt on a variety of laptops, some of which are quite small … so don’t blame your hardware. dt is highly optimised and even without OpenCL it is blindingly fast.

That was I believe initially his problem…ie that he could not seem to select any files in lighttable to initiate the copy/paste…if it was selected copy would not be grayed out as he noted so I am not sure what exactly the issue was but I think he was looking in the right place just something was amiss …and the opencl issue in the past has resolved some weird graphics and ui quirks so it can be something to try if there are weird issues with graphic elements. Integrated Intel graphics drivers were a problem at some point but this may also have been resolved…@Dunehunter did you ever get this sorted out??

If one can‘t do some actions it’s usually not related to opencl. If one can do something and this results in a messedup image this might be an opencl issue.
On windows the antivirus might messup stuff - this might be a reason if one can’t do something.
So it’s helpful to be precise if something can’t be done or simply doesn’t have the expected results

This did seem weird that the user was able to double click the thumb and go into darkroom to edit but not seemingly able to select an image in the lighttable and do a copy and paste. I noticed last night that simply hovering over an image enabled the option selection buttons in the history operations pane of lighttable and then when you move off it they grey out. I wonder if this was confusing the user into thinking that he had selected it but then it didn’t remain selected?? However one would assume that you would be aware if you had actually clicked on the thumb for selection or not vs hovering but I guess you should never assume anything and your point is for sure well taken. It is amazing when someone takes the time to really describe the problem in detail it can usually be solved quickly…

A single click on the ‘slide’ was specifically mentioned.

Ya that is why it really didn’t seem to make sense…