ModuleNotFoundError: No module named 'sip'

Hello there,
After running the install script when I try to run ./rapid-photo-downloader I get the following message:

Traceback (most recent call last):
  File "./rapid-photo-downloader", line 7, in <module>
    from raphodo.rapid import main
  File "/home/xyz/.local/lib/python3.6/site-packages/raphodo/", line 74, in <module>
    import sip
ModuleNotFoundError: No module named 'sip'

Can anyone advise me on this?

Have you tried pip3 install sip ?
raphodo.rapid has import sip but the install script doesn’t have sip in the list of requirements.
If that doesn’t work python3 -m pip install --user sip might.

Try this:

pip3 install -U PyQt5

In the past few days there were some problems with the release of the latest versions of PyQt5 and Sip, which are developed by the same person. PyQt5 cannot run without Sip, which is why there is no need to specify Sip as an additional dependency.

Hopefully the situation with PyQt5 and Sip will resolve itself shortly.

It seems like some bug with PyQt5.

I tried "pip3 -m install -user sip and got an error stating:

distributed 1.21.8 requires msgpack, which is not installed.

I installed the Ubuntu package golang-github-hashicorp-go-msgpack-dev and now I’m getting a new error:

ImportError: /home/username/.local/lib/python3.5/site-packages/PyQt5/ undefined symbol: PySlice_AdjustIndices

PyQt5 now has a private version of SIP unique to it. The sip you installed is no longer intended to work with PyQt5.

This is why I strongly suggest this command (with the --user switch if not on a Debian derived distro):

pip3 install -U PyQt5

That way, the PyQt5 sip will be automatically installed and you don’t need to think or worry about it. Uninstall the version of sip you manually installed.

I know it’s a hassle to have to mess around with this pip stuff. Sorry to everyone about that. Unfortunately at the moment I do not have time to set up a PPA with deb packages, or produce an installer with snap or flatpak or appimage. It’s just impossible for me right now.

Please install the latest version 0.9.10 using the script.

I’m getting the same problem (on Fedora 29).

I tried

pip3 install -U PyQt5

and get:

ImportError: cannot impot name 'main' from 'pip' (/usr/lib/python3.7/site-packages/pip/

do this:

pip3 install -U --user PyQt5 PyQt5_sip

Do not prefix with sudo.

I get the same error

Please elaborate, showing exactly what you are doing when you get an error. If possible copy and paste the output from a terminal.

It looks like you installed pip for your user, and now it won’t run because something is conflicting with the system’s pip installation.

Pip is a tool to install python packages. Until you resolve the problem with it, you cannot install Rapid Photo Downloader or any other Python programs using your user.

I suggest asking how to resolve the pip problem in a forum that is geared toward new Fedora users.

I haven’t (knowingly) installed pip. And I’m not a new Fedora user either, having used it since it came out.

Anyway, that was sufficient clue for me. I found a local installation of pip and removed it. Now installation completes.

Thank you.

1 Like

Back in the good old days, each Linux distro had a package manager. All you needed to do was learn how to use one package manager to maintain your system. Install, update, remove … one package manager to rule them all.

Now we have about a dozen to deal with. Everyone has to have their own f’ing package manager. It’s a pita enough for development libraries and so on, but now end users need to learn them all too? Then we wonder why people just blindly follow commands posted to internet forums and get their systems screwed.

Nuts. I’ve used rapid for years, but …

I’m sorry to be blunt @dcrobertson01, but I don’t understand the point you are making. Can you elaborate?