-morph_files Does it recover from a crash?


(Peter Lavender) #1

OK, not the best title, but what I’m asking is when using the -morph_files option, ie gmic -w -morph_files ./*.jpg,3,0.5,5,0,-1,1,morphed/out.jpg will gmic know where it got to from the last time it was run in this location?

Guess I can read the doco to see if there’s a ‘start image number’ option… :slight_smile:

I’m faced with 172 jpg files, there are 84 files in the output directory, so based on 3 images per original image that’s 28 images processed, so I could remove those 28 and kick the processing off again.

The reason for the crash doesn’t look like gmic, but due to the CPU getting too hot and the system failing in trying to slow the CPU down, you can see this here:

Jan 4 12:53:44 piglet kernel: [166584.414775] CPU2: Package temperature above threshold, cpu clock throttled (total events = 815205)
Jan 4 12:53:44 piglet kernel: [166584.414777] CPU4: Package temperature above threshold, cpu clock throttled (total events = 815206)
Jan 4 12:53:44 piglet kernel: [166584.414778] CPU6: Package temperature above threshold, cpu clock throttled (total events = 815205)
Jan 4 12:53:44 piglet kernel: [166584.414779] CPU7: Package temperature above threshold, cpu clock throttled (total events = 815206)
Jan 4 12:53:44 piglet kernel: [166584.414780] CPU0: Package temperature above threshold, cpu clock throttled (total events = 815205)
Jan 4 12:53:44 piglet kernel: [166584.414781] CPU3: Package temperature above threshold, cpu clock throttled (total events = 815206)
Jan 4 12:53:44 piglet kernel: [166584.414783] CPU1: Package temperature above threshold, cpu clock throttled (total events = 815206)
Jan 4 12:53:44 piglet kernel: [166584.414784] CPU5: Package temperature above threshold, cpu clock throttled (total events = 815205)
Jan 4 12:53:44 piglet kernel: [166584.415724] CPU5: Package temperature/speed normal
Jan 4 12:53:44 piglet kernel: [166584.415725] CPU3: Package temperature/speed normal
Jan 4 12:53:44 piglet kernel: [166584.415726] CPU1: Package temperature/speed normal
Jan 4 12:53:44 piglet kernel: [166584.415726] CPU7: Package temperature/speed normal
Jan 4 12:53:44 piglet kernel: [166584.415727] CPU4: Package temperature/speed normal
Jan 4 12:53:44 piglet kernel: [166584.415727] CPU0: Package temperature/speed normal
Jan 4 12:53:44 piglet kernel: [166584.415728] CPU6: Package temperature/speed normal
Jan 4 12:53:44 piglet kernel: [166584.430280] CPU5: Core temperature above threshold, cpu clock throttled (total events = 650516)
Jan 4 12:53:44 piglet kernel: [166584.430280] CPU1: Core temperature above threshold, cpu clock throttled (total events = 650516)
Jan 4 12:53:44 piglet kernel: [166584.431248] CPU1: Core temperature/speed normal
Jan 4 12:53:44 piglet kernel: [166584.431454] CPU5: Core temperature/speed normal
Jan 4 12:53:44 piglet kernel: [166584.906855] CPU6: Core temperature above threshold, cpu clock throttled (total events = 379794)
Jan 4 12:53:44 piglet kernel: [166584.906856] CPU2: Core temperature above threshold, cpu clock throttled (total events = 379793)

Not long after that the system had hung and I had to hard reset.

Not a GMIC issue, other than it was using as much resource as available to it.


(David Tschumperlé) #2

Ah, no there are no such mechanism with command -morph, sorry :slight_smile:
I suppose anyway that you could just change your filename pattern to make it match only the new input files you want to process. Is that something doable ?


(Peter Lavender) #3

All good, I thought I’d ask. I did a quick test to confirm some basics…

In the basic test I did it over wrote the out_000000.jpg file already in the output directory.

I’m sure a little scripting hackery would sort it out, however I ended up doing the blunt tool approach and start all over again. So far the server has remained up.

I tried setting the nice value to see if it would make any difference, not sure that’s really working as it is used I think to solve CPU utilisation contention not so much ‘slow’ a program down by having less time on the CPU.


(Flössie) #4

No, nice is not the way to go. Best would be to repair/replace your CPU fan. Second best is to throttle the CPU by using the powersave governor:

# echo powersave | tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor >/dev/null

Good luck
Flössie