Natron 2.3.14 crash, possible bug


(Siddhant Rane) #1

Natron 2.3.14 crashes on running the second time.
That is, for some reason, I close natron and open it again, It starts normally, but as the splash disappears, Natron crashes.
I have to restart Windows to start Natron again.

System:
Windows 10 (latest update)
Intel i7-6700K
GTX1080Ti (latest drivers)


(Omar Brown) #2

Completely uninstall Natron and then reinstall it.

Also try these snapshots and see if they help at

https://downloads.natron.fr/Windows/snapshots/RB-2.3/64bit/files/Natron-RB-2.3-201808081849-f1d5182-Windows-x86_64bit-no-installer.zip 2

https://downloads.natron.fr/Windows/snapshots/RB-2.3/64bit/files/Natron-RB-2.3-201808081849-f1d5182-Windows-x86_64bit-setup.exe


(Siddhant Rane) #3

I did try reinstalling it completely (both versions) but that didn’t help.
I’ll try the snapshots.
(The issue is only with 2.3.14)


(Siddhant Rane) #4

Experiencing the same issue with the snapshot.


(Siddhant Rane) #5


(Meng-Han Ho) #6

Try to run Natron from command line with --no-cache and --no-settings flag to see if this is a preference or cache issue. If still crashes, see if it leaves some clues in terminal.

${YOUR_NATRON_BIN_FOLDER}/Natron.exe --no-cache --no-settings


(Siddhant Rane) #7

Ah, it works if I run it from cmd with those flags…
Can you explain what that does? Not familiar that much with command line…


(Meng-Han Ho) #8

Ooops… My bad. it should be --clear-cahce not --no-cache

–no-setting : Natron will restore default preference before it runs
–clear-cache : Natron will clear all cache before it runs

Maybe Natron just ignore wrong argument?
But, this is good, since cache was not clear, only preference had been restored to default. We now know it’s your preference issue. However, this flag, I believe, only temporarily restore preference, The problem is that on my Windows machine, I could not find where Natron store preference, nor can I save over default preference using --no-settings flag. For now, you can use --no-setting from terminal, or add to your shortcut, until you find a way to actually reset your preference.

Best,


(Siddhant Rane) #9

Yeah I could do that. But here’s the catch:
I’m not using the default color management. I’m using the Blender Filmic color management. And as you might’ve guessed, Natron requires to restart every time you change the color management presets.
So I’m basically stuck in an infinite loop xD


(Siddhant Rane) #10

At least I know where the problem is coming from…
Thanks a lot!


(Meng-Han Ho) #11

Maybe @devernay knows the proper way to reset preference on Windows.
I am also interesting to know why Natron with --no-settings can not save over preferences.


(Siddhant Rane) #12

Are preferences for different versions saved separately? Because as I mentioned earlier, 2.3.13 is working perfectly fine on my system.


(Meng-Han Ho) #13

That’s the thing. I could not even find where Natron store preference on windows machine. Otherwise, you would simply delete the preference file, and let Natron regenerate it.


(Meng-Han Ho) #14

Well, I came up with this solution by using Natron Python. It’s pretty straight forward and it works on my machine.
Go to Your Terminal( the following basically run natron in interactive mode with python interface)

${YOUR_NATRON_BIN_FOLDER}/Natron.exe -t

Once it finished loading bunch of stuffs. you will see >>> waiting for your input, now you execute following line by line.

NatronEngine.natron.getSettings().restoreDefaultSettings()

NatronEngine.natron.getSettings().saveSettings()

exit()

Now, you should be able to open Natron normally with default preferences. Hope this works on your machine.

Best,


(Siddhant Rane) #15

That worked like a charm! Thanks a lot!


(Siddhant Rane) #16

Okay so I’ve been working backwards restoring my previous preferences and after setting the second last preference (OFX plugins path) I’ve come to a conclusion that the last remaining preference, i.e. PyPlugs might be the problem. I don’t know what exactly the issue might be, because the same plugins are working in 2.3.13.