Natron - Output looks different than Viewer

Hi everyone

I’m new to Natron and already have an issue with my color settings. I have an exr sequence with the read note settings: File colorspace: linear/linear and Output colorspace: linear/linear.
On my write node: Input colorspace: linear/linear and file colorspace: sRGB.

In my viewer I’m pretty happy with the result but once I render it as a .mov ProRes4444 it looks completely different than what I had in Natron.(see screenshot) Is there a way to get the same output as in my Natron viewer?

Thanks for your inputs.

Can you send 1 exr frame? I don’t think this is the same issue as Huân mentioned which is just a misunderstanding of Natron’s colour management UI (frankly I’m not sure why the “output colourspace” option exists in the read node but maybe there’s a specific scenario why you would want it over another OCIO node).

I thought Devernay’s reply is the answer.

ENA4_CU_03_i1_1_0037.exr (60.9 MB) ENA4_CU_03_i1_1_0029.exr (60.7 MB)

Attached the exr. I will try with the OCIO node. Thanks!

Colourspace transforms are funny like that and also largely dependant on ensuring that the program that is reading the file to interpret it correctly. I think you had your read and write settings correctly configured but just in case go ahead and delete both the read and write nodes.

Read node for EXR should be set to linear for both file and output

Write node for Prores 4444 should be set to input linear, output sRGB. When I tested this in Nuke the default for Prores is Gamma 1.8 however VLC expects it to be sRGB, when set to sRGB of course both behave as expected.

What program are you importing this to? It may expect Prores to have a different gamma curve and doesn’t interpret the file the same way which makes the highlights look blown out.

I tried it with the OCIO node and with the new read and write node.

I go to Premiere Pro to make the cut.

One thing that’s really weird… when I review the file (with Quicktime) straight out of Natron it looks like the right preview of my earlier screenshot. Once I take it into Premiere it looks completely fine like in Natron. But then again the final render out of Premiere is like the screenshot again.

I don’t use Premiere but what is your color management settings in that software? If you use the setup as Hank suggested, you should set the input in Premiere to sRGB, and the viewer to sRGB to appears correctly.

Here is what it looks like Davinci Resolve:
image

Input is the color space of the footage, the “timeline” is for the “adjustment” and output is for the viewer and render.

As far as I know you can’t set the colorspace in Premiere. I’ll try it with Davinci. Maybe it looks better there. Thank you!