Need help in getting transparent background


This is a sample of my problem. In GIMP I hade the moving lines (ants) around the horse head. I want put a similar image onto another image. I had used smart scissors/ Edit, clear and select, invert. I get the green background. When I try to move it into another image the background stays with it. I noticed when I start GIMP and create a new image, I get a box with the same color. Is that the root of my problem?

Thanks for your help. This is stifling my creativity.

Not familiar with GIMP, but when I understand correctly, you make a selection around the head, invert selection and delete everything except the head?

Sounds like adding an alpha channel before doing this should then give you a transparent background.

Do right click on the layer β†’ add alpha channel before you delete anything from the image.


Apart from that, you propably could also simply copy & paste (Ctrl+C, Ctrl+V) the selected head without needing to invert and delete anything.

1 Like

Probably. If you look at the Advanced Options in File β†’ New there are options for Fill With and Background Color is the usual default. If green is your background colour, that is what you get.

That gets carried over when you cut a selection without setting an Alpha Channel for transparency. Use Layer β†’ Transparency β†’ Add Alpha Channel.

Then you can cut out the background and copy / paste or as this demo Drag-n-drop does work.

40 second demo:

As a note: If you have an image with transparency and export it in a format that does not support transparency, such as jpeg, any transparent areas are again replaced by the current background colour.

1 Like

I am positive that your problem is saving the file as a JPG. JPGs don’t save transparency so save as a tiff file. If problem persists then I can provide more information on how to do what you want.

1 Like

The video looks good but is too fast for me. Is there any way to slow it down?


I’ll try to work with what Rich2005 sent to me. I did try using the tif but did not have any luck yet. I’ll try working on Rich2005’s video first.

The essentials:
By default, Gimp β€˜remembers’ the last settings used. If you set the background colour to green, that is what you get With File β†’ New or when transparency is replaced, as when Exporting a jpeg

Before cutting the selection add an Alpha-Channel Layer β†’ Transparency β†’ Add Alpha-Channel. If there is already an Alpha Channel that option is greyed-out. There is a visual hint in the layer name. No Alpha name is bold font. With Alpha layer name is regular font.

You can cut the selection Edit β†’ Cut or Delete the selection Edit β†’ Delete.

By default, transparency in an image shows as a checker board pattern.

If everything is fine, Save that image as a Gimp .xcf, which keeps all sorts of image properties, including transparency. Otherwise Export the image as (usually) .png format, alternatively as a .tif

If you have the image open in Gimp and you want to add to another Image there are several ways.

If you still have the background selected, Invert the selection, Select β†’ Invert

Copy the selection Select β†’ Copy (or ctrl-c) and the easiest way in the destination image is Edit β†’ Paste-As β†’ New Layer in Place. Use the move tool to adjust position of the layer.

If you have Saved or Exported the image. Open the destination image. Then File β†’ Open as Layers that image you just made. It is a new layer. Move it around with the move tool.

1 Like

Worked well for me:

haws-pasted with xparency

Pardon the β€˜fuzzy’ selection tool getting some of the horse!

Okay. I first uninstalled GIMP then reinstalled it. I was finally able to do what I wanted. That way I was able to avoid the green background. I found that to copy and paste the image had to be fully opaque. Then after it was pasted I could select the floating image and adjust the opacity, size and position. I was able to save the image into a JPG file.

Thanks everybody for your help. This is a great resource.