.NEF image turns completely black when opened in Raw Therapee


First time user of Raw Therapee;

When I open a raw file (.nef), it turns completely black (see screenshot below). This version is saved as a .pp3 file. Does anyone have any idea why it is doing this and what I can do to fix it? I did a bunch of googling but couldn’t find anything regarding this specific problem.

The thumbnail in Raw Therapee showed the image until I opened it. Then it went black and now that is all it shows. The image still comes up fine when looking at or open the image via the File Explorer.

I am at a total loss

Welcome…post your raw…something is up… just upload it using the upload button in the post reply dialogue

1 Like

It’s huge, sorry :grimacing:
Z9A_1405.NEF (33.8 MB)

Screen Shot 2023-04-01 at 10.03.43 PM

With the metadata-exiv2 branch I can read that you are on a newer model camera that might not yet be recognized by the software.

1 Like

Hi @J_Peach
I can confirm your file has the same behavior on my machine - I’m still running a 5.9 release candidate version of RT but same result - odd.
I then tried in darktable and this error message - yet the thumbnail still shows fine.
Maybe that Nikon is too new? I’ve forgotten where the list of supported cameras is - will try and find it.

1 Like

You beat me to it - BTW I see that metadata in 5.9 too.

1 Like

Is this file from the Nikon Z9 with their new high efficiency encoding? None of the Foss software supports that format yet, since its all under patent.


Thanks all. It’s not my camera but it could be a new fancy one as the friend who owns it is a professional photographer. Any suggestions on how I can get around this issue?

1 Like

Yes, it is quite a new camera. I believe it is supported, at least in darktable, but not when shot in the high efficiency RAW mode, which this shot is I think.
A workaround that I can confirm works is to convert the file to DNG using Adobe’s free DNG Converter - darktable and RawTherapee then work fine with the DNG file.
Not ideal if you’re doing it everyday perhaps, but fine for odd jobs. I don’t think any quality is lost in the DNG conversion.
Edit: This only works on Win and Mac… but I think you’re on Win so should be fine.


Great, thank you! I’ll give that a go :slight_smile:

1 Like

Hi J_Peach,

I am having the exact same problem as you with my NEF images from my Nikon Z8. Did you manage to find a fix for it, and if so, please can you share it with me?

Nikon High-efficiency and high-efficiency* encoded Z9 .NEF RAW files won’t decode.
Try turning off the high-efficiency*/high-efficiency.