NEFs "has unknown format"

RawTherapee and Darktable uses 2 different raw file reading libraries. That’s the difference.
A file being supported in one of the software does not imply it’s supported in the other one, but it could since there is another open-source implementation.

(If you still have the D3100) what happens if you take new photos with it and try to import them into darktable?

The d3100 was my backup camera, and I sold it 5 years ago, but now I’m left with 32GB of imagenes…

But than for the tip :slight_smile:

Yes at least I can always process my 32GB of D3100 NEFs in rawTherapee, but I’d have to make a new workflow and in my experience Darktable has better watermark support, so…

But would it be wrong to conclude that it is not my NEFs that are broken, but Darktable?

Thanks a lot :slight_smile:

SO it is NOT my NEFs that are corrupted…

Cant express what a joy that is…

IT must be a v3.0.1 or a Linux version problem, I guess…

Any one tried it on Linux?

Thanks for the tip, but @grsnovi managed to open my example file without any problems, so guess it not a file problem :slight_smile:

Sorry, i must have misunderstood

I thought you managed to open MY example NEF…

Please disregard all my comments about it being unbroken…

I tried to download the NEF in the thread, and it didn’t even open in rawTherapee as my NEFs do…

I tried opening your file 2013-02-16@17-15-0802.nef in darktable 2.6.2 on Ubuntu 18.04 LTS. A thumbnail showed up fine in lighttable, but when I tried to open it in darkroom, I got this message:

failed to read camera white balance information from '2013-02-16@17-15-0802.nef'!

and the photo does not open. I’d suggest having a look at the thread that @Thomas_Do linked.

1 Like

No, your NEF would not open but others that I downloaded opened fine. I got the same error with your file that you did. Sorry for the confusion.

1 Like

Ping @LebedevRI

1 Like

It is a bit strange. The file opened fine for me in RT 5.8, Photoscape X, XnView MP, Adobe Bridge. But in darktable I can see the thumbnail in the import dialogue but then get “file has unknown format” message in lighttable mode.

1 Like

This is not a proper bug reporting method, please use issue tracker

1 Like

I knew was a reasonable chance you might say that, sorry, I’ll go through the proper channels :slight_smile:

@Soren_Garup I took the liberty to create an issue on the darktable GitHub. You can find it here: https://github.com/darktable-org/darktable/issues/5149

2 Likes

I wouldn’t call darktable “broken”. There is a bug in rawspeed (the library that darktable uses ) and it deserve a proper bug report, as Roel just did for you :wink:

1 Like

It would be really helpful to preserve such a raw on https://raw.pixls.us/
Can you find some such affected raw that has no people in it,
that you’d be willing to contribute to RPU?

1 Like

Thanks for the bug reporting :slight_smile:

This was the conclusion from @LebedevRI :

#The problem is:


That looks for TIFF IFD that contains an entry with tag 0x8c ( ContrastCurve ?)
Clearly, it is not present in that raw, so we fail."

END

As I understand it Darktable will not handle the file due to missing information in the file, but rawTherapee will handle the same file despite the missing information.

Since Darktable is not broken, I guess there will be no bug-fix to the problem?

And I will either have to make a new workflow for rawTherapy or find some other work-around?

I have 32GB of NEFs from my now sold D3100, so I’m sure there must be a few without humans in them…

How many do you want and where do i upload them?

The internet is full of reports of corrupted NEF files. Often these files were changed (destroyed?) by the transfer software. The example file of @Soren_Garup also the following information in the header: “Nikon Transfer 2.0” and has obviously been edited by that software.
For the future, I can only recommend to use file transfer tools that do not edit the files themselves.

1 Like

I have this problem with NEF files from a D3100 that have been edited (even viewing them may be enough) in View NX2. View NX2 changes the raw file from a big-endian to little-endian TIFF wrapper (if you check the header it goes from II to MM). This is on the macOS version of View NX.

Not sure if this is the same issue as @Soren_Garup is seeing but I do still have the camera so I can get some sample files togther if that would help.

1 Like