NEFs "has unknown format"

Hi All!

Processing my whole archive in Darktable, I ran into problems, when I tried to import some old NEFs from a Nikon D3100.

Darktable refuse to open the files, stating that the NEFs “has unknown format”

I suppose NEF from Nikon d3100 are supported in Linux since they work fine in rawTherapee?

Anyone know if this is a Darktable problem, and if, is there any hope that “old” NEFs from D3100 will ever be supported in Darktable?

Thanks in advance!

I’ve had a d3100 and never had problems with the raw files.

Could it be that you processed the old D3100 NEF files using Nikon Capture NX2 in past (which is known to modify the NEF files) ? Just a thought…

1 Like

Thanks for the fast answer…

Did you process D3100 NEFs in Darktable 3.0+?

As far as I remember the NEFs are unprocessed, just copied directly to the harddrive…

Ok, as I wrote, it was just a thought.

Thanks for the thought…

its so may years ago, and I do remember using Nikon software on Windows, before I was enlightened to Linux…

but IF they are damage by Nikon software, why would they still be fine in rawTherapee in Linux?

Just did to try:

May I ask to the version number of your Darktable?

3.0.2 installed from debian testing or unstable


maybe @heckflosse was right that I damaged the files long time ago with Nikon software…

I just don’t understand how they still works in rawTherapee if they are broken…

Any chance to upload a NEF to this site, for others to try?


2013-02-16@17-15-0802.nef (11.8 MB)

Thanks for the hint, no need to say I’m a beginner uploader on this site :slight_smile:

1 Like

Hello Soren, nef files, or raws in general, are never modified by raw software. Perhaps Nikon software did that (as Ingo suggested), can’t comment on that.
Because Rawtherapee reads them fine, I guess the problem resides with Darktable. I own a predecessor of your d3100, the d40, and those nefs never pose problems in whatever software.

Maybe the corruption is related to the situation described in this thread.

but if they are “corrupted” why would they work fine in rawTherapee?

no, that’s why I think it is a Darkroom problem, but I don’t know if it is just my 3.0.1 version of Darktable or all versions?

If anyone have time to download the NEF it would be a great help…

Thanks in advance

Soren - doesn’t open in my v3.0.0 on Windows. I get a preview but it complains about unknown format.

1 Like

Does this utility help?

For what it’s worth, my v3.0.0 has no problem opening example NEF’s downloaded as examples…