New version Just doesn't work!

Oh dear! I’ve been using a Siril version, can’t remember which but I installed it in September last year, just fine up until now.
I saw there was “the latest” version so installed it and deleted the older version.
Now I’m stuck. The newer version just doesn’t seem to work.
I have selected the “home” file where the RAW lights and darks are, pressed the QSC_Preprocessing but just get the error:
14:53:09: No files were found for convert
14:53:09: Error in line 18: ‘convert bias -out=…/process’.
14:53:09: Exiting batch processing.
14:53:09: Script execution failed…

I have tried two go back to the old version, which worked just fine, but can’t find it. Now I’m stuffed, can’t do any processing.

HELP PLEASE

Hi, I think this could help you: https://siril.org/first-steps/
You may take a look and if it still doesn’t work, please show us your directory structure from the current working directory set in siril.

Thanks for the quick reply Vincent. Yes that is what I was reading. I did a screen shot of my screen when I tried to run the QSC script…

I am NOT using Biases or Flats, just DARK and LIGHTS.

Ah, looking top centre it shows the path leading to STACKING, which is where the image folders are but when the script runs it seems to default to STACKING-biases which is why I’m getting the error!!

How can I go back to the version I first downloaded at the beginning of September 2020 please?

Even when I download 0.99.4 older version I still get the same problem and can’t find anything older! HELP

if you don’t have bias images, you need a script without them, it is not provided with the installation, but you can find it here: https://free-astro.org/index.php?title=Siril:scripts#Getting_scripts

1 Like

Thanks for that, I’ll have a look! As I PM’d you, I have re loaded 0.99.4 from my backup disc and it ran fine but the second time I opened it there was no “Scripts” button at all??

Many thanks again, followed the link instructions and got the “Scripts” back.

Most helpful. Now, dare I try the new version…:roll_eyes:

Got the scripts back but they are the “new” ones, the QSC_…thingies even though I’m in version 0.99.4!! I need the old scripts which were there when I first opened the app, with the "no flats, no biases etc.

This is incredibly confusing to an old man😩

OK, I’ve found and downloaded “OSC_Preprocessing_WithoutFlat.ssf”.
but how do I get it into Siril 0.99.4 please :weary::flushed:

I am NOT that computer savvy I’m afraid but I do my best.

First don’t use version 0.99.4. It contains many known bugs.
Second, put the file where you want and tell to Siril where it is (in Scripts tab in preferences).
Then follow the first steps tutorial.

This is driving me MAD!!
I have deleted 0.99.4 and installed 0.99.6
On opening there is no Scripts button.
Go into preferences, Scripts and delete the three scripts that are there - press Apply.
Re start Siril.
Open preferences, scripts and put the script [OSC_Preprocessing_WithoutFlat.ssf into it and press Apply
Close and Re open Siril, NO SCRIPTS button again!
Go into preferences and the three lines that I previously deleted are back again and the one I put in isn’t!

What is going on, I’m just going round and round in c circles!!

Everything worked fine until I tried the update :weary::weary::weary:

Right! I have now uninstalled all old versions and installed 0.99.8
I have put the script “OSC_Preprocessing_WithoutFlat.ssf” into the Preferences/scripts folder. Pressed “Apply”.
Restarted the App but it does not appear under the Scripts button…

you need to write a path. Not a filename.

Thanks lock042, I worked that out and it worked and I ran the script, all well although it rejected many of the RAW images the older version accepted.
I have now “Opened” the result.fit and processed it but it seems to be black/white, no colour in it at all?
My processing path is:
Create desktop folder with three folders in it, Lights, Darks & Biases.
Change Directory in SiriL to this folder.
In Scripts run Processing-no flats
OPEN result.fit in desktop folder.
Change “Linear” to Auto-Stretch.
In IP select Colour Calibration - carry out functions and Apply.
In IP select Remove Green Noise - Average Neutral - Apply
Change Auto Stretch back to Linear
In IP select Histogram Transformation
Drag “cut” pointer to the right - Apply
In IP select Asinh Transformation - drag pointer to right - Apply
CROP as necessary
In IP select Background Extraction - Degree 4, Samples 15.
Right click to remove any green squares on subject - Apply.
In IP select Asinh Transformation - black slider to right and Apply.
In IP select Colour Saturation - adjust as required.
Save file as…………

Am I missing something?? Is there a step by step tutorial somewhere please to get the best results.

I’ll come back to you with a list if I can find it, crop must be done first for example, to not mess with the images statistics used by other tools.

Click on the rgb tab.

Thanks guys, helpful as always. Here’s the imported result.fit in RGB, plenty of green in there as I guess it should be called RGGB.

Ive also found several TUTORIALS on YouTube which I will work through but a workflow list would be most appreciated Vincent, thanks.

I think I’m getting there…

This is using 0.99.6 so I’ll have a go with the latest 0.99.8 later :grin:

Here’s the promised list: https://siril.org/faq/#in-which-order-should-image-processing-functions-be-used

1 Like

Many thanks Vincent, most hepfu😎

Just read through the list but it doesn’t seem to list how to MANUALLY process the RAW images, just running scripts. Sorry if I’ve missed something.
I would like to learn how to do manual RAW processing using the Conversion, Sequence, Pre-processing, Registration, Plot & Stacking on the right hand side of the App. At the moment I haven’t a clue what they all mean or do or how to even start the process.
Cheers