New Windows builds


(Morgan Hardwood) #202

We need stack backtraces! There’s a good reason sguyader also makes debug builds.
http://rawpedia.rawtherapee.com/How_to_write_useful_bug_reports


(Flash) #203

Hi Morgan, thanks for your answer!
I’ve installed the latest release (4.2.967) and changed the ClutsDirectory to ClutsDirectory=C:\MyEmptyFolder (which exists).
Unfortunatelly the problem persists.


#204

@Morgan_Hardwood
Backtrace of HaldCLUT crash uploaded as per instructions.
[At least that is what I hope – this is the first gdb/RT session I’ve every made.]
RT 4.2.974 Win 7, 64-bit, 12 gig RAM, English version.


(Sebastien Guyader) #205

New Windows 64-bit builds are here: http://filebin.net/047o539v44

They should fix the HaldCLUT bug.

Edit: link updated


#206

Uh oh,
The tag you are trying to access has expired and does not contain any files.


(todd) #207

What Claes said.

(Uh oh,
The tag you are trying to access has expired and does not contain any files.)


(Sebastien Guyader) #208

Sorry, I updated the link in the post above.


(Mark Howell) #209

Thank you, the Hald CLUT bug has been fixed in 4.2.976!!!


#210

New Windows 32-bit builds(release and debug) are here

master branch 4.2.835
GTK3 branch 4.2.976


(Edward Kiefer) #211

Ok ,I have gt3 4.2.976 installed.

problem is when I start RT, I get a dos window in back ground with warning messages (RT does run, just a delay for second or 2).
here warnings
rawtherapee.exe:4900: Gtk-warning **: Failed to fetch network location: error opening directory ‘C\program files\Rawtherapee-4.2.976\network’: : No such file or directory

PS I delected option file to but same thing


(Ingo Weyrich) #212

The warnings are from gtk3. Nothing we can do here. But you can set verbose=false in your options file. That should suppress the ‘dos’ window.


(Edward Kiefer) #213

It is false already, seems to be default setting

Verbose=false

Anyway, it seems to work fine, haven’t saved anything yet but looks ok.
Thanks, will just use it then as is.


(Ingo Weyrich) #214

Please check whether you have more than 1 options file. On my machine options files for gtk3 and gtk2 are in different folders for example.


#215

Did you install the “Debug” or the “fast” version?


(Edward Kiefer) #216

I am on Win7 Pro 64bit and default is C:\Users\Ed\AppData\Local\RawTherapee
for options (there no gtk2,3 folders in there.
There is gtk2, gtk3 folder in for example C:\Users\Ed\AppData\Local\gtk-3.0
but has nothing to do with RT AFAIk and is empty.


(Edward Kiefer) #217

installed release version, not debug one.
Edit:
Hehe, looks like I did install debug by mistake.

Sorry guys, I really didn’t think I DL the debug version, all is ok with release version


#218

New Windows 32-bit builds(release and debug) are here

master branch 4.2.852


(Sebastien Guyader) #219

@Morgan_Hardwood please let me know when you merge Master into Gtk3, I’ll make the Windows builds.


(Morgan Hardwood) #220

@sguyader @gaaned92 I merged master into gtk3.


(Ilias Giarimis) #222

Not really a new build but an updated camconst.json
https://drive.google.com/file/d/0B0NqktTgc54sZTRsbE9IUlhzeUE/view?usp=sharing
it is already commited but if new builds for your OS are late, you can just replace the old with this one to test with new cameras and/or problems with magenta highlights on old cameras etc

I will post the changelog in some hours …