New Windows builds


#324

Hm… of course, that could be a clue.
Try a clean install of RT 4.2.1234 and do not set any CLUTS path.

Addendum:
I also have a faint memory of some postings at the end of May
to the effect that if the CLUTS directory contained empty files,
then RT would misbehave…


(Morgan Hardwood) #325

Do you have any network drives set up?

About CLUTs: RawTherapee has code which will show a warning if loading CLUTs takes more than 10 seconds or if you have more than 500 or 1000 files in or under the CLUTs folder, forgot what the exact number was. I don’t know what happens in Windows when there is no CLUTs path set at all. Hopefully then nothing gets scanned. But if you want to be sure that it’s not CLUTs, then just create an empty folder such as c:\empty and set that as your CLUTs folder in RT’s Preferences.


#326

I am not sure what you mean by ‘network drives’. I have a few directories visible on my local network and I can access them from other devices and my tablet PC also has some public directories. That’s all.

I have already created an empty CLUTS folder since I saw some posts talking about that. The empty CLUTS directory didn’t help. Anyway I don’t see why RT would behave differently on Window and Linux with respect to CLUTS and I have not issue with CLUTS on Linux – I don’t use CLUTS yet.

I have a flash. I have many hard disks and I remember I disabled indexing on Windows at some point since Windows is installed on a SSD and I have tried some SSD specific settings. I had to play with some SSD specific settings on a tablet PC after I had replaced the HD with a SSD. I will look at that.


#327

OK, here is a far-fetched idea: in Win10, navigate to the directory containing
rawtherapee.exe using Win’s ordinary file browser
(presumably the directory will be C:\Program Files\RawTherapee-4.2.1234)

Now shift-right-click and select open command window here
type rawtherapee.exe and hit Enter
after a short while RT starts. Drag its window to one side so that you
will be able to see any error messages &c in the command window.

What happens at your place?

Addendum: I also have a bunch of SSDs here and I do not believe that they are to blame.


#328

I will try that. I mentioned SSD’s because I believe I disabled indexing on the SSD and I can see in Explorer that windows is taking some time scanning directories (progress bar on the upper part of a Explorer/File manager window). That is not normally a problem but if RT needs to maintain an internal map of the drives, then that could slow down RT – just a guess.


(Morgan Hardwood) #329

That could be the cause - I recall there was a problem with network drives and locations slowing RT down. Just a guess - I don’t use Windows for reasons.


#330

Hi, I start RT in a command shell as you suggested. It takes 3 min to get a white window and an additional minute to have the picture icons displayed.

There is no message whatsoever from RT in the command shell.

Within RT it takes an additional 48 s. to get the options window on the screen.

I also looked at indexing. I disabled the indexing service and started RT and the start time remains the same at around 4 min. I reactivated indexing, rebuilt the index, and the starting time is still at 4 min.

People might think that I have huge problems with that PC, but it works fine (4 cores, 2.5 GHz, 8 GBytes RAM, SSD). Before RT, I needed to use SilkyPix on Windows to process my raw files. SilkyPix starts in 10 s.

So I will try again in a few months. That’s not a big deal for me since I use RT in Linux anyways and I am so lucky to have RT on Linux in the first place.


(Mica) #331

Have you tried running RT in compatibility mode?


#332

Quite right. I also had good reasons to choose my PC’s so they would run Linux. Windows excellent handwriting recognition has no equivalent though, so I run Windows on my slate/tablet PC which is 32-bit and a bit underpowered and not a good choice to run RT!


#333

Thanks for this. I am trying compatibility with Windows7 right now. I have started RT a couple of minutes ago, and I still have no window opened.

I will try Window8 to make sure.

Still no window…


(Ingo Weyrich) #334

Does that also happen with build from master branch (gtk2) ?


(Ilias Giarimis) #335

Deactivate non existent Floppy Disk Drives from your device list …
I had the same problem with win 10 showing disk drive A as present/active while I have no floppy on my machine.


#336

Thanks ilias_giarimis. There is no A: drive listed anywhere on my system.

I also ran IOBit Advanced System Care cleaning the registries and that did not help either.

I will live it there. Another computer mystery…


#337

Just a point of information,
I know nothing about programing and only a fair amount about computers, but I have been using RT for several years now and it ran just fine in W7 64bit and also now in W10 64bit… But, since the GTK3 builds, it opens slower but does not run any slower!


#338

The master branch build takes 2 min to load (half the 4 min it takes the gtk3 buid to load). Displaying the configuration panel takes an additional 24 s (against 48 s for gtk3).

Once started, the gtk2 build is lively, quite as lively as my Linux build.

Right now, the gtk2 build is a better option for me than the gtk3 build.

Install details.

  1. Uninstalled the gtk3 build.
  2. Installed the gtk2 build.
  3. Removed directory AppData/Local/RawTherapee.
  4. Reboot (just to make sure).
  5. First run, setup and exit. Time measurement done on following runs.

My problem is the startup. I will keep using the gtk2 build for now.


#339

I timed RT on my Win10-machine:
After re-boot, double-click on RT icon on desktop.
RawTherapee 4.2.1234 (GTK3-version) starts in 9 seconds.

I have not set any compatibility modes.

Afterthoughts:
Do all other programs start slowly or is it just RT?
Are you running the SSDs in IDE or AHCI mode?


#340

Some more timings for comparison:

On my rebooted 4 years old Win7 desktop (i5, 16 GB, 2 x HD) 4.2.1069 (master) starts in 8 seconds, after closing and reopening, in 3 seconds. On my Win10 modest laptop (i3, 8 GB, SSD + HD, from grocery store), this takes 6 s and then 4 s.

Gtk 3 version was slower, when I tried it for the last time, but not much, about a second or so.

Edit: was slower to start


(Morgan Hardwood) #341

As @Claes asked, have you tried other Gtk±using programs, such as GIMP? How fast they they start?

FYI: The Gtk3 version takes slightly longer to start (1-3 seconds, depending on your system), but apart from startup time it runs just as fast as the Gtk2 version.


#342

Just in case:

I don’t remember Windows 10 being available for upgrade from Vista. Was it?

Also, you probably have some kind of anti-virus installed, plus the SmartScreen “feature”, that prevented me from installing multiple open source programs, before I disabled it. (It checks “unknown” programs against the MS whitelist.) Did you check this?


(Ingo Weyrich) #343

Thanks for testing gtk2 branch. I guess it’s related to this issue. If you have a filesystem with lots of folders this damn FileChooserButtons take a lot of time. Maybe that’s even worse on Win10