Newbee Raw Therapee fail - can't see a thing....

Ok, a newbee RT fail. I installed the program, gingerly navigated (File Browser) to my directories with pics and nothing shows up in the middle of the UI, even in folders where there are pics (not expecting roll-up). Long time (+10 years LR and C1 user… so not my first kick at imaging software).

Where did I go wrong?

/roast me…

What OS? What RT version? What format are the files you’re trying to view in? Have you read the getting started page of the docs?

What OS?
Win 8.1 & Win 10

What RT version?
Latest download 5.8

What format are the files you’re trying to view in?

Have you read the getting started page of the docs?
Tried to but got a 500 Internal Server Error from

in the filbrowser window/ folder pane

  • click on triangle to expand a folder
  • double click on folder to see the thumbnails
  • first time, the thumbnail is the extracted jpg
  • when the image is processed, the thumbnail is the processed raw ( approximate of course)

hope it helps waiting for rawpedia

I guess it’s a time thing … I tried what you wrote above. Nothing. Walked to the other computer, tried there. Nothing. Came back and the thumbnails were there. Seems this is a lot slower then Capture One, but that’s ok, it seems to work. Patience I guess. Thanks for the help.

If it is your first time navigating to a folder, RT will take a minute to generate the thumbnails.

It shouldn’t be that slow… Like @gaaned92 says, the first thing RawTherapee does is try to extract the embedded thumbnail from your files. That should be fast, because there is very little processing involved. Besides, the generation of thumbnails is multi-threaded. So in theory you should see thumbnails popping up over time.

Do you have a virus scanner active by any chance? Or are your files on a network storage or external drive?

Please check whether the file extensions are enabled in Preferences

And not long ago, I had problems with RT and ART who wer very (very) slow to start and display the thumbnails.
It happened that my NAS (only used for backups) was connected (W10) and there was some access problem, also in the explorer. The only disk I open in the two apps is a local disk.
I disconnected the NAS and the two apps became again as before.
Beware of network disks.

Thanks all for the feedback, great forum it seems looking around a bit.
It seems for whatever reason, the thumbnails are generated very slowly.
No virus scanner running, just the default Windows virus stuff and malware. Never seems to cause an issue elsewhere, but maybe?
I am not running the files off a network, all is coming from the computer. The extensions were enabled thanks.

Looking at the Task Manager, I don’t see anything unusual. I do see that it’s caching the previews to the C: drive which is going to take up a lot of space fast on C: Not such a fan of that as I want to keep C: lean and mean. Files live on E: only in this household :slight_smile:

Interestingly enough, the first folder I exposed, my last set of pics, did show up as mentioned before with a big delay but when I navigate to other folders, the thumbnail previous do not change. I can highlight and expand a folder in the file browser to the lowest level, but the thumbnails stay the same. Very strange. I also don’t see any writing activity into the cache, so maybe it’s hanging up somewhere. Task manager shows a little bit of CPU use for RT. The RawPedia page is up again it seems so I’ll go poke around there.

The same for the story above. Just an unused NAS connected that made the apps and filebrose hanging.

The NAS I have is a true NAS, and attached to the wifi router via RJ45, it’s not a “NAS” attached via USB to the computer. It’s on standby unless addressed. I turned off wifi but it made no difference, just to be sure.

Bad guess :frowning_face:
There is something that gets in the way of RT.

I will install 5.8.
Where do you install it? How many photos do you have in a folder?

I’m not sure I understand it correctly, but just in case: when you select a folder, do you double click on it?

  • I installed RT5.8 official in program files.
  • I deleted the existing config dir.
  • then creted a photo dir with about 1300 photos.
  • start RT,
  • double click on above photo dir.
  • immediately thumbnails are displayed
  • then they are progressively built and displayed as I scroll down in the directory.
  • takes about 20 sec on a i7-6700K to generate all thumbnails.

So, I cannot reproduce.
As noted above, thumbnails are generated once and written in the cache (inside the config dir).

Different hypothesis:

  • network disk or network folder mapped. (already eliminated)
  • anti virus,
  • execution of rawtherape-debug.exe instead of rawtherapee.exe
  • ???

True to the title, it’s a Newbee Raw Therapee fail. Double click is where the issue was. Both Lightroom, Capture One (and others) show the files on single click. All good now. Nice and fast! Thanks for investigating and bearing witness to my stupidity :slight_smile:


You are welcome @Malindi.
The double click is an idiosyncrasy of RT , but its very fast to be used to and it avoids to inadvertently make RT generate useless thumbnails.

1 Like