Newbie - and can't find preferences in Raw Therapee

The wiki says that the icon is in either the top right or bottom left, but I’m not seeing it :frowning:

You’re in single edit mode. Did you right click & open with RawTherapee? If so, you won’t see the button. Open up RawTherapee from the start menu. It will be on the lower left hand side.

5 Likes

Thanks - you were correct…I had to open the application directly and then it was visible.

Now…on to the next, but related, issue - in the preferences I put in the path to my Gimp directory but clicking on edit current image in external editor doesn’t open the image in Gimp. Is there something more I need to be doing to get it to work?

is there a bin folder inside gimp-2.10-22 folder? The path needs to be to where the gimp.exe is.

I have a GIMP-2.10.22.exe in the gimp top level folder under Program Files and gimp-2.10.exe in the bin folder - neither seems to do it. I did use the line code C:\Program Files\GIMP-2.10.22\gimp-2.10.22.exe, and that works, but I’m curious why selecting the folder doesn’t. It does work for PS2021 by selecting the folder.

Thanks

Just a thought: RawTherapee looks for gimp.exe and not gimp-some_version_related_string.exe

Not sure how to do this in Windows, but you can check this by making a link named gimp.exe in that directory that points to, in your case, gimp-2.10.22.exe.

Anyway: Using the complete path that includes the executable always works.

EDIT: My just a thought turns out to be wrong, see Roel’s answer below.

I solved it by modifying the “options” file in Windows that is in appdata.
In the section:
[External Editor]

I manually put my GIMP path: (with double \)
GimpDir=C:\\Program Files\\GIMP 2

Remember to have closed RT before modifying options.

This is not true, RT actually looks for a version number. However, it can only detect a major.minor numbering scheme like gimp-2.10.exe but not anything else.
You should also point to the main installation directory and not the bin subdirectory.

If you do that and GIMP does not load, I’m not sure what is going on tbh.

For reference, the relevant code: https://github.com/Beep6581/RawTherapee/blob/eb8f121709c37b38ada6cee9eb6f27b9b4767027/rtgui/extprog.cc#L274-L284

1 Like

While this could work, it should be identical to modifying the path through the Preference dialog. If it isn’t, there is a bug in the code somewhere…

From preferences I can’t: I find empty Program Files.


Can you do it?


Solved: You don’t have to choose “Archivos de Program” in my own language but you have to choose Program Files.


Sorry for the confusion

Putting the path in is what’s working for GIMP. Selecting the folder in Program Files doesn’t. It works for Photoshop though. This is how I have it set up:

Yes, that is correct. Like I said: “RT actually looks for a version number. However, it can only detect a major.minor numbering scheme like gimp-2.10.exe but not anything else.” You have a different numbering scheme (working with an unstable version?), so it won’t detect it automatically.

1 Like

So, I guess I have to wait till the next major version gets released.

Can’t you just rename gimp-2.10.XX.exe to gimp-2.10.exe? Or does Windows not allow that?

Minor bug-fix releases are coming available on a regular base (GIMP 2.10.24 was released in late March or early April). Renaming to exclude the minor number might be a workable solution.

Or you can file a feature request to encourage us think of a smarter way to detect a GIMP runtime executable :wink:

1 Like

Tried it…no dice…but at least putting in the path to the .exe works