Nikon z6II color issue

Hi all, new Rawtherapee user here. I have noticed that Rawtherapee displays the NEF files of my z6II all desaturated and washed out. Is there a setting that fixes this? Thanks in advance for any help!

Can you tell us a bit more?

If you load a RAW, any RAW, it will be washed out to begin with. But that is assuming you did not apply any (automatic) profile. or didn’t do any editing.

If I look at the 2 Z6II RAWs that I have lying around then they are, as expected, “washed out” when I load them. Applying one of the standard profiles gives me a reasonably nice looking image (still needs work in my opinion, but that’s not the point I guess).

Profiles I tried:

  • Processing Profiles -> Bundled profiles -> pop -> pop 1
  • Processing Profiles -> Bundled profiles -> Standard Film Curve -> ISO Low

If the above is not the issue, please elaborate a bit.

I tried the processing profiles, but it didn’t help. I also noticed that, with my old D750, there is no such issue. I just open a NEF in the rawtherapee file browser, and the colors are spot on, just like in any other raw converter I have tried (like my old Lightroom or dxo). Is it possible that the z6II is not yet fully supported in Rawtherapee?

If your RT version is old, it probably doesn’t have the Z 6ii color primaries. I just looked at the RT camconst.json file in the dev branch and they’re not there yet.

Since the Z 6ii is supposed to have the same sensor as the Z 6, they can probably use the same numbers, just need to make an entry with the camera make and model that will match the raw metadata. There’s a way to make a user-specific camconst.json, I don’t know specifically where to put it, but you could take the Z 6 entry, change the make/model, and put it in a user camconst.json to get by until RT is updated.

3 Likes

Thanks, I’ll experiment with this.

I just gave @ggbutcher’s idea a try and that works.

Quit RawTherapee. Find your camconst.json file (in the rawtherapee directory) and look for the following lines:

{ // Quality C, only color matrix and PDAF lines info
    "make_model" : "Nikon Z 6",
    "dcraw_matrix" : [8210, -2534, -683, -5355, 13338, 2212, -1143, 1929, 6464], // Adobe DNG Converter 11.1 Beta ColorMatrix2
    "pdaf_pattern" : [0, 12],
    "pdaf_offset" : 32
},

Copy and paste that block just below and change: Nikon Z 6 to Nikon Z 6_2

You should be good to go, even though this is a dirty hack :slight_smile:

Without the hack:


And with:

2 Likes

It works, thanks a bunch! :smiley:

1 Like

Keep in mind that putting the Z 6ii entry in the RT-installed camconst.json will get overwritten if you update RT.

Just went looking for the way to add a user camconst.json; the instructions are actually in camconst.json at the very top. Cut-n-pasted for convenience:

"All changes made here will be lost on software update. If you want to add custom values or change existing ones, create
a "camconst.json" file next to your personal "options" file. Its values will then override and/or complete the ones of
this file."

This page tells you where to put it:

https://rawpedia.rawtherapee.com/File_Paths

3 Likes

That is correct. But…

This is true for a standard build. If you have, like me, multiple RawTherapees installed (stable x 2 + development) and 2 of those in non-standard locations the method described will not work.

For the non-standard builds the options and camconst.json file are both in the same directory as the rest and will be overwritten. I really need to refine the cmake options (DCMAKE_INSTALL_xyz=…) in my script to separate the install dirs or add a nice sed or awk statement to set things right. But I’m a lazy bastard at times :grin:

1 Like

I’ve overwritten the main comconst file for the time being as I just tried this out on a development version, but I will definitely create a custom file as described in the link you provided. Hopefully this won’t be necessary anymore once the new version is out. Anyway, thanks to both of you, I really appreciate your help!

4 Likes