No processing...


#1

Hi!

Now I have installed RT 5.4. But I can’t process an image. If in the Editor I click the little sprocket at bottom left, nothing happens. Now I can’t go back to 5.3, which worked earlier, it’s the same there. Re-starting the Mac (10.11.6) doesn’t help. What can I do?

The image in question is a file from a Fuji E900.

Thank you for your help.


(Sebastien Guyader) #2

When you click on that sprocket, the image goes to the queue. But then, you need to go to the Queue tab, and turn queue processing on.
If you check “Auto-start”, next time an image goes to the queue, it will automatically process.


#3

Thank you for your post Sebastian. - Earlier, after I clicked that sprocket, the number of images put to process was displayed in the Processing tab. Not now. - I tried to go to the Processing tab none the less, but then RT crashed.


(Sebastien Guyader) #4

Sorry but I don’t know Mac… Have you tried with images from another camera? Maybe it’s bad support for raw files from this camera, or maybe an issue with your specific installation, which could be solved by reinstalling the program and deleting the options file?


#5

Concerning re-installing: it is a fresh download and install. -
It is the same with a file from a Sony a7r2. And since you are not on a Mac, you’ll probably not be able to tell me where I might find that ‘options’ file. Thanks none the less!


(Ingo Weyrich) #6

ping @HIRAM as he’s the mac specialist :wink:


(Morgan Hardwood) #7

Record and show a video of what you’re doing.

http://rawpedia.rawtherapee.com/File_Paths#Config


#8

macOS

~/Library/Application Support/RawTherapee/config/

Under the Finder’s ‘Go’ menu click ‘Go to Folder’ (shortcut Command+Shift+g), you can then type/paste any path you want to navigate to, even if it’s hidden.

I’d try deleting that.
Try saving a jpg conversion before trying out the queue. If the queue crashes again. Grab the system crash report and post it here.


#9

Thank you both for your replies.

Now I have installed RT 5.4.

I deleted the ‘options’ file, but with no change. Meaning after I clicked the sprocket, nothing happened. When I clicked the Processing tab, RT crashed. I’ll try to post the log.

It is here:
https://www.dropbox.com/s/0jhzr2et2nygl33/RT%205.4%20crash%20log.rtf?dl=0

Also, RT seems incredibly slow compared to earlier.

BTW I don’t understand how I can save a jpeg if the processing doesn’t work -?

Now I’ll try to record that video.


#10

Hm, I don’t know how to. I thought I remembered there was a way to record screen movies using Quick Time, but that seems to have gone. There is only a QTplayer to be found in the Application folder.

Well there was not much to show in that video: the mouse pointer moving from the Editor image to the sprocket at bottom left and clicking there; then to the vertical Queue tab at left; then crash. One would think the crash log records that?


(Morgan Hardwood) #11

Close RT, delete your cache and config folders, re-download RT 5.4 from http://rawtherapee.com/downloads and see if that helps.


#12

The crash is identical to this crash from last year:


What was going on was a problem with a french character, é, in the folder name. The fix was made to the executable loader script.
What is the pathname of the file you are trying to process?
There is also an issue with accented characters involving the use of English language in a non-English speaking region, like having the system region settings on EN-de (English/Germany)…

Regarding the single-image processing… Instead of clicking the sprocket, click the disk icon next to it to save just the one image without going thru the queue.


(Morgan Hardwood) #13

http://rawpedia.rawtherapee.com/Saving_Images


#14

Close RT, delete your cache and config folders, re-download RT 5.4 from http://rawtherapee.com/downloads and see if that helps.

Yes it did!

Yes there is an asterisk in the file path. This has earlier been a problem, I couldn’t open files at all. But now, files do open, so I had not exspected it would cause problems later in the process. For now, I moved the raw file to the Desktop, and that worked. Both the direct single saving and the queue.

Except that the name field in the top of the Queue window is clipped. I report on that together with other clippings in the thread

Some problems with RT 5.3 and 5.4

Thank you for your help!