OCIOCDLTransform missing CCCID field

The OCIOCDLTransform and OCIOFileTransform nodes are missing the CCCID field. I’m getting the error from the nodes to select the CCCID for a given CDL/CCC file but the field is missing from the node parameters. I’ve tried v2.3.15 and v2.4 on macos. The docs list the CCCID field but I don’t see them.

The tooltip mentions that the file can be either a .cc or .ccc file, and I notice that you are using a .cdl file. That could be the issue.
Can you try using a .cc or .ccc file? The CCCID field could be hidden until the proper file is used.

Yes, it’s a bug. This field should be enabled for .cdl too. To make it appear, set the filename to something ending with “.ccc”, then edit the cccid, then change the extension back to .cdl.

It will be fixed in the next version

fixed in OCIOCDLTransform: cccid must always be enabled · NatronGitHub/openfx-io@ebc9a36 · GitHub
(there probably won’t be another beta before end of August, but you can still use the trick above)