Open in Filmulator from Exporer (Windows) or Digikam possible

I just discovered this project and I must say that I’m impressed by the results particularly in correcting images with a high dynamic range.
I use digikam to manage my photos and I tried to open an image from there. Filmulator starts but doesn’t open the image. It seems that I would have to import images first but I must say that I find the managing part of Filmulator not very intuitive and would prefer to stay with Digikam.
Is it possible to just open an image im Filmulator from Explorer or digikam instead of having to import them first?

It’s not a simple change to make, since I architected it from the beginning around the database.

But I’ve been asked this before so I’m playing around with some ideas, like having any files passed in as inputs automatically imported and appended to the queue for easy access.

Or maybe I could hide all the tabs and the queue like RawTherapee, and do the importing and selection in the background?

As for the in-built management, I’m going to add tags, but it’s mostly just a way to access images in chronological order, showing you how many pictures you took per day in the histogram at the top. Can you tell me what you were confused by?

If Filmulator will open a file from a command line invocation, you could simply have the installer make a desktop shortcut. I have had goodness with rawproc in just dragging an image file to such a shortcut. Don’t know how this would play with the database, though…

Well, then it is obviously not yet possible to open directly. I thought I possibly missed something.

To me, the database and the organizer tab are not necessary. What I find counterintuitive is that I have this filmstrip at the bottom and have to scroll a long way to find the image I want to develop instead having the images in the center. Personally, I don’t sort pictures by day taken. When I develop a picture, I pick them by tags. Additionally, at least in my version of Filmulator the calendar doesn’t exist so selecting pictures to be shown in the middle is somewhat difficult.

But it would be sufficient to have the opportunity to directly open an image in Filmulator and perhaps to hand it over to Gimp in the end. :wink:

The filmstrip at the bottom is a purely temporary work queue and you can empty it—right click on an image and select “clear entire queue”.

Then you can add images from the organize view by either double-clicking on them individually, or by using the “enqueue all” button at the left (seen in your screenshot).

1 Like

Thank you! Is there any option that in the organize view all imported pictures are shown? And how do I get the calendar view?

Nevertheless, I would very much like to be able to open an image from command line/explorer/digikam directly to filmutlator instead of being forced to import.


  1. You can view all pictures by selecting a date on one extreme of the date histogram, then shift-clicking a date at the other extreme. Or by double-clicking and right-clicking.
  2. The calendar view is gone, because the framework for it was removed from Qt 6 and I decided to omit it in preparation.
1 Like

I’ve gotten opening from command line working on Linux. The command is filmulator -i [path_to_image], pretty simple.

It doesn’t do anything wonky to the UI; it imports, enqueues, and loads the image but it doesn’t switch to the Filmulate tab automatically.

Next I need to check that it works with the AppImage, and figure out how to get Inno Setup to do the goods on Windows so you can right-click and open with Filmulator.

EDIT: builds are up on the nightly build thread. Try them out.

Thank you for your effort and the quick release. Unfortunately it doesn’t work. Right-clicking an image and opening with Filmulator does the same as before - nothing. Do I have to tweak something before?

Does it not even launch at all from the right click menu?

Have you tried opening it from Digikam? Can you configure the commands it gives?

I tried both, opening from Explorer and from Digikam. In both cases Filmulator starts but the image is not imported. Both of them use the same way of opening. I can’t configure much besides creating a batch file for opening.

When Filmulator starts, there should be a terminal window that comes up as well, for the latest build.

Can you copy in what it says on startup? Just the first ten lines should be enough.

Here you are:

Have 2 arguments
C:\Program Files\Filmulator\filmulator.exe
18:17:27.593 creating qapplication
18:17:27.667 creating qqmlapplicationengine
18:17:27.676 connecting to database
18:17:27.760 creating settings object
18:17:27.763 creating parametermanager
ParamManager load defaults to params
ParamManager directory string: C:/Users/xxx/AppData/Local/filmulator/version_2
ParamManager initializing lensfun db
ParamManager done initializing lensfun
18:17:27.781 assigning parametermanager property
18:17:27.783 connecting parametermanager
18:17:27.785 creating filmimageprovider
ParamManager load defaults to params
ParamManager directory string: C:/Users/xxx/AppData/Local/filmulator/version_2
ParamManager initializing lensfun db
ParamManager done initializing lensfun
18:17:27.788 creating importmodel
18:17:27.788 creating organizemodel
18:17:27.788 creating queuemodel
18:17:27.789 creating lensselectmodel
18:17:27.790 loading qml file
18:17:30.763 creating window
18:17:30.774 showing window
18:17:30.988 return

Looks like if I remove the -i argument then it’ll just work…

I’ll try that tonight.

Try RC5 from the nightly builds thread.

Now it works! Thank you very much!

I would like to give something back. What about translating Filmulator into German? If you give me a hint which file to translate, I would like to start.

1 Like

3 posts were merged into an existing topic: Translating Filmulator