Opening 2 files from desktop Creates 2 app instances rather than 1

Hi there, I am new to RawTherapee but not new to photography or raw editing.

The app itself is great, but I have a question about opening files & how the interface varies which is confusing me.
When I open the RawTherapee app directly I see the standard view that is explained in the docs with tabs for Files, Queue, Editor on the far left & clicking “Editor” i see the film strip for images at the top.
However, when I open files from my desktop or a folder, perhaps a few at a time, It launches multiple instances of “Editor” for each image. There is no film strip & there is no panel on the left to access Files, Queue or Preferences etc

Now. The way I work I much prefer to select images in my OS & open them, jumping right into the Editor. But how can I set this up so it opens the standard app & not as multiple instances of a minimal Editor?

Thanks for your advice.

I should mention I am using RT version 5.8 on Ubuntu 21.04

1 Like

This behaviour is “correct”. I put correct between quotes because the way this works at the moment is a (unwanted?) remnant from the past.

You can start RawTherapee in 2 modes at the moment:

  • File browser mode (when you start RawTherapee. The full blown one that you expected)
  • No-file browser (“simple”) mode.

The second is triggered when you click on an image/raw file on your desktop (or external file browser) and tell it to open with, rawtherapee in this case. This has the side effect that if you select 2 (or more) files and use open with that multiple RawTherapee instances will be started.

There’s a PR github issue about changing this behaviour: Get rid of no-File-Browser mode (simpleEditor) #2238 I’m not seeing all that much progress, but there does seem to be some.

This doesn’t solve your problem but does explain what is going on.

EDIT: It is an issue, not a PR that’s filed on github.

1 Like

ahh thanks for the info. That explains it then.

Yikes! That discussion has been going for 6 years.
That whole file browser column is rather clumsy imo. Just File > Open could replace the cluttered tree diagram.

But anyway, thanks for the advice & now I know how to proceed.

Check the documentation Command-Line Options - RawPedia and search for the command line option -R and change the settings linked to the menu in your file browser

Thanks. This seems to be what I need.
I am however struggling to understand what to do exactly. How do I turn on -R mode permanently?

I’m using Ubuntu 21.04 & Im rather new to Linux, could you explain “change the settings linked to the menu in your file browser” in more details. Sorry!

I’m looking at RawTherapee > Prefs > File Browser but I don’t see that option.
In my OS File Browser, viewing properties of a ARW file, I can see ‘open with’ but not really any way to set -R.

Here I did not mean the file browser in RT but in your operating system. In Windows it is in the registry, in linux in a profile, but don’t ask me how exactly. IIRC it was something like a .rc or something like that