Desperately trying to get this OSC_Extract_HaOIII.ssf script incorporated in siril.
Used Siril with different scripts worked fine, downloaded this script, but it doesnot show up although it is in my downloadmap tried the circular arrow but nothing helps. Finally downloaded Siril (1.0.3) one more time, but the script does not show up in Siril.
Please help!

To see scripts in Siril, everything is explained here: Siril:scripts - FreeAstro

I finally succeeded in getting this HaOlll script in Siril
But now I got this message: The script you are executing need a newer version of siril to run 1.0.1
But at Siril.org I only see 1.0.3 as the newest version
My Mac runs Osx 10.13.6

Where did you get the script? I bet it is a script for the dev version and it is not compatible.
You don’t need to download this script, OSC_Extract_HaOIII.ssf is a standard script provided during installation.

I used to work with older version of siril which I upgraded, Also deleted some scripts which I did not use. But I got a new camera and would like it very much to use the HaOlll script.
So, to get this OSC_Extract_HaOIII.ssf script I deleted siril from my computer and downloaded and installed 1.0.3 but there is only one script in it, actually the same script as I used. Seems I could not delete swirl completely and install 1.0.3 again.
How could a make such a completely new beginning?

Just as you need.
You should share the script you try to run.

OSC_Extract_HaOIII.ssf (1.7 KB)

I downloaded it from free astro

But deleting swirl completely and downloading and installing again should work ?

Yes this is what I said. This version is for dev version. You shouldn’t do it.
Don’t download scripts, just siril. It will provide the scripts you need.

Deleted siril completely and made a new download. Scripts are there and everything works fine.