Overexposed areas get magenta outline


(Denys Kuzmenko) #1

IMG_9713.CR2 (23.1 MB)

See light on the background in the middle of the image.
Whe I load it with “Default” profile I get while circles with magenta outline.
Guess it happens for a reason explained here: http://www.darktable.org/2016/10/raw-overexposed/

But how to fix that with RawTherapee? I tried changing HL Reconstruction settings, it didn’t help.
Positive (>1) Raw White-point correction helps somehow but worsens situation with other nearly overexposed areas to an unacceptable level.

JPEGs produced by camera itself are Ok.


(Andrew) #2

Defringe in the Details toolbox pretty much fixes it.


(Shreedhar Inamdar) #3

In addition to the Defringe moule, I used the LH and CH curves in the LAB tab to reduce the chromaticity and increase the luminosity of purple. Have a look:
IMG_9713.jpg.out.pp3 (10.7 KB)


(Morgan Hardwood) #4

Using a DCP from Adobe DNG Converter and enabling Defringe, you beat the out-of-camera JPEG with minimal effort.
Canon EOS 700D.pp3 (9.4 KB)
Canon_EOS_700D_Adobe_Standard.dcp

Make sure that when you apply the PP3 that it picks up the DCP, so that in the Color Management > DCP section the checkboxes are enabled, as in my screenshot.

Neutral:

Canon EOS 700D.pp3

Then you can set this PP3 as your default PP3 for raw files.


(Ilias Giarimis) #5

Using sRGB as working space also helps for desaturating fringes :wink:


(Denys Kuzmenko) #6

Thank a lot to everyone!
From now on DCP is apllied by default for every photo.
I have also installed newer RawTherapee with Defringe tool.